summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Gautier2018-05-27 17:27:02 +0200
committerRomain Gautier2018-05-27 17:27:02 +0200
commitc5918590de31a298127c7cdfd5a7e499b98d8e14 (patch)
tree921a0c173cbcf0cd603a89b289e7e80d9ff0fec9
downloadaur-c5918590de31a298127c7cdfd5a7e499b98d8e14.tar.gz
Ship emacs-xwidgets
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD55
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d5227938a01
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = emacs-xwidgets
+ pkgdesc = Good old emacs with xwidgets support
+ pkgver = 26.1_rc1
+ pkgrel = 1
+ url = http://www.gnu.org/software/emacs/emacs.html
+ arch = x86_64
+ license = GPL3
+ depends = librsvg
+ depends = gpm
+ depends = giflib
+ depends = libxpm
+ depends = libotf
+ depends = m17n-lib
+ depends = gtk3
+ depends = webkit2gtk
+ depends = hicolor-icon-theme
+ depends = gconf
+ depends = desktop-file-utils
+ depends = alsa-lib
+ depends = libmagick6
+ depends = gnutls
+ provides = emacs
+ conflicts = emacs
+ source = ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-26.1-rc1.tar.xz
+ source = ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-26.1-rc1.tar.xz.sig
+ validpgpkeys = B29426DEFB07724C3C35E5D36592E9A3A0B0F199
+ validpgpkeys = 28D3BED851FDF3AB57FEF93C233587A47C207910
+ sha1sums = 8ba00629a1799c14e02c643e26bb9fa5009ae8fa
+ sha1sums = SKIP
+
+pkgname = emacs-xwidgets
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86aefcd405f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+#
+# Maintainer: Romain Gautier <romain.gautier at nimamoh dot net>
+#
+pkgname=emacs-xwidgets
+pkgver=26.1_rc1
+pkgrel=1
+
+# custom variable. the underlying true pkgname
+appname=emacs
+appver=${pkgver::-4}
+
+pkgdesc="Good old emacs with xwidgets support"
+arch=('x86_64')
+url="http://www.gnu.org/software/emacs/emacs.html"
+license=('GPL3')
+depends=('librsvg' 'gpm' 'giflib' 'libxpm' 'libotf' 'm17n-lib' 'gtk3' 'webkit2gtk' 'hicolor-icon-theme' 'gconf' 'desktop-file-utils' 'alsa-lib' 'libmagick6' 'gnutls')
+conflicts=('emacs')
+provides=('emacs')
+validpgpkeys=('B29426DEFB07724C3C35E5D36592E9A3A0B0F199' '28D3BED851FDF3AB57FEF93C233587A47C207910')
+# ftp://alpha.gnu.org/gnu/emacs/pretest/
+source=(ftp://alpha.gnu.org/gnu/emacs/pretest/$appname-${pkgver//_/-}.tar.xz{,.sig})
+sha1sums=('8ba00629a1799c14e02c643e26bb9fa5009ae8fa'
+ 'SKIP')
+
+build() {
+ cd "$srcdir"/$appname-${appver}
+ PKG_CONFIG_PATH="/usr/lib/imagemagick6/pkgconfig" \
+ ac_cv_lib_gif_EGifPutExtensionLast=yes ./configure \
+ --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
+ --localstatedir=/var --mandir=/usr/share/man \
+ --with-gameuser=:games \
+ --with-mailutils \
+ --with-x-toolkit=gtk3 --with-xft \
+ --with-xwidgets \
+ --with-modules
+ make
+}
+
+package() {
+ cd "$srcdir"/$appname-${appver}
+ make DESTDIR="$pkgdir" install
+
+ # remove conflict with ctags package
+ mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
+ mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1}
+
+ # fix user/root permissions on usr/share files
+ # XXX: emacs stores using major version. Since we build a rc we have to strip things down
+ find "$pkgdir"/usr/share/emacs/${appver} -exec chown root:root {} \;
+ # fix perms on /var/games
+ chmod 775 "$pkgdir"/var/games
+ chmod 775 "$pkgdir"/var/games/emacs
+ chmod 664 "$pkgdir"/var/games/emacs/*
+ chown -R root:games "$pkgdir"/var/games
+}