summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJon Eyolfson2015-08-11 11:05:48 -0400
committerJon Eyolfson2015-08-11 11:05:48 -0400
commit7c08ac53e1900a18f523ea9838480c513fae9f3c (patch)
tree219d395e83a35d9f7a4c4b245b66622dbc7801eb
downloadaur-7c08ac53e1900a18f523ea9838480c513fae9f3c.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
-rw-r--r--yasnippet.install13
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3de7bae25173
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = emacs-yasnippet
+ pkgdesc = Yet another snippet extension for Emacs.
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = https://github.com/capitaomorte/yasnippet
+ install = yasnippet.install
+ arch = any
+ license = MIT
+ depends = emacs
+ source = https://github.com/downloads/capitaomorte/yasnippet/yasnippet-0.8.0.tar.gz
+ md5sums = fa343adae588fde44b4ecf4f23c1e2d0
+
+pkgname = emacs-yasnippet
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a148d2e7a82d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Hauke Wesselmann <hauke@h-dawg.de>
+# Maintainer: Gianmarco Brocchi <brocchi@poisson.phc.unipi.it>
+pkgname=emacs-yasnippet
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="Yet another snippet extension for Emacs."
+arch=('any')
+url="https://github.com/capitaomorte/yasnippet"
+license=('MIT')
+depends=('emacs')
+source=(https://github.com/downloads/capitaomorte/yasnippet/yasnippet-$pkgver.tar.gz)
+md5sums=('fa343adae588fde44b4ecf4f23c1e2d0')
+options=()
+install=yasnippet.install
+
+build() {
+ cd $srcdir/yasnippet-$pkgver
+ install -d $pkgdir/usr/share/emacs/site-lisp/yas
+ cp -r * $pkgdir/usr/share/emacs/site-lisp/yas
+}
+
diff --git a/yasnippet.install b/yasnippet.install
new file mode 100644
index 000000000000..b9222c5efad8
--- /dev/null
+++ b/yasnippet.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo " add the following in your .emacs file:"
+ echo " (add-to-list 'load-path \"/usr/share/emacs/site-lisp/yas\")"
+ echo " (require 'yasnippet) ;; not yasnippet-bundle"
+ echo " (yas/global-mode 1) ;; or manually load it with yas-global-mode"
+}
+
+post_upgrade() {
+ post_install
+}
+pre_remove() {
+ echo "If you like remove the yasnippet stuff from your .emacs"
+} \ No newline at end of file