summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:24:34 +0200
committerStefan Husmann2015-06-09 00:24:34 +0200
commit55764f9e5e769fbd135be7627677e087824cf784 (patch)
tree445dc3b963a8b5c1d3ba1b5545655f003540c9c5
downloadaur-55764f9e5e769fbd135be7627677e087824cf784.tar.gz
initial version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
-rw-r--r--yasnippet.install14
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d9960d450a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-yasnippet-git
+ pkgdesc = Yet another template system for Emacs - git version
+ pkgver = 0.9.0_beta_40_g197db9f
+ pkgrel = 1
+ url = https://github.com/capitaomorte/yasnippet
+ install = yasnippet.install
+ arch = any
+ license = GPL
+ makedepends = git
+ provides = emacs-yasnippet
+ conflicts = emacs-yasnippet
+ source = git+https://github.com/capitaomorte/yasnippet
+ md5sums = SKIP
+
+pkgname = emacs-yasnippet-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb80129b11f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+pkgname=emacs-yasnippet-git
+pkgver=0.9.0_beta_40_g197db9f
+pkgrel=1
+pkgdesc="Yet another template system for Emacs - git version"
+arch=('any')
+url="https://github.com/capitaomorte/yasnippet"
+license=('GPL')
+makedepends=('git')
+provides=('emacs-yasnippet')
+conflicts=('emacs-yasnippet')
+install=yasnippet.install
+source=('git+https://github.com/capitaomorte/yasnippet')
+md5sums=('SKIP')
+_gitname=yasnippet
+
+pkgver() {
+ cd "$srcdir"/$_gitname
+ git describe --tags|sed 's/-/_/g'
+}
+
+package () {
+ cd "$srcdir/$_gitname"
+ install -d $pkgdir/usr/share/emacs/site-lisp/yas
+ cp -r * $pkgdir/usr/share/emacs/site-lisp/yas
+}
diff --git a/yasnippet.install b/yasnippet.install
new file mode 100644
index 000000000000..8d40b7ac8523
--- /dev/null
+++ b/yasnippet.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo " add the following in your .emacs file:"
+ echo " (add-to-list 'load-path \"/usr/share/emacs/site-lisp/yas\")"
+ echo " (add-to-list 'load-path \"~/.emacs.d/plugins/yasnippet\") and create that directory"
+ echo " (require 'yasnippet) ;; not yasnippet-bundle"
+ echo " (yas-global-mode 1)"
+}
+
+post_upgrade() {
+ post_install
+}
+pre_remove() {
+ echo "If you like remove the yasnippet stuff from your .emacs"
+} \ No newline at end of file