summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinRs2019-04-29 00:05:45 +0800
committerLinRs2019-04-29 00:05:45 +0800
commitaa3ae858675e6f77046295ff40db2d4d68a8e64f (patch)
treef575f0d7e4eadf8889de7a5181760772c68f0445
parent96ff7726cda85150e56941a4f26c6715501e8a97 (diff)
downloadaur-aa3ae858675e6f77046295ff40db2d4d68a8e64f.tar.gz
upgpkg: emacs-yasnippet-git 10.13.0.r28.gfc33b2f-1
- use ruby-rake build the package following upstream
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD36
2 files changed, 31 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cec4a8a87e8..ed8fca6cca93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-yasnippet-git
pkgdesc = Yet another template system for Emacs - git version
- pkgver = 0.13.0.r7.g7a178a2
+ pkgver = 0.13.0.r28.gfc33b2f
pkgrel = 1
epoch = 1
url = https://github.com/joaotavora/yasnippet
@@ -8,10 +8,12 @@ pkgbase = emacs-yasnippet-git
arch = any
license = GPL
makedepends = git
+ makedepends = ruby-rake
+ depends = emacs
provides = emacs-yasnippet
conflicts = emacs-yasnippet
- source = git+https://github.com/joaotavora/yasnippet
- md5sums = SKIP
+ source = git+https://github.com/joaotavora/yasnippet.git
+ sha256sums = SKIP
pkgname = emacs-yasnippet-git
diff --git a/PKGBUILD b/PKGBUILD
index c280b12d2190..5702112e189a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,43 @@
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Maintainer: LinRs <LinRs at users.noreply.github.com>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+
pkgname=emacs-yasnippet-git
epoch=1
-pkgver=0.13.0.r7.g7a178a2
+pkgver=0.13.0.r28.gfc33b2f
pkgrel=1
pkgdesc="Yet another template system for Emacs - git version"
arch=('any')
url="https://github.com/joaotavora/yasnippet"
license=('GPL')
-makedepends=('git')
+depends=('emacs')
+makedepends=('git' 'ruby-rake')
provides=('emacs-yasnippet')
conflicts=('emacs-yasnippet')
install=yasnippet.install
-source=('git+https://github.com/joaotavora/yasnippet')
-md5sums=('SKIP')
+source=("git+${url}.git")
+sha256sums=('SKIP')
_gitname=yasnippet
pkgver() {
- cd $_gitname
- git describe --tags|sed 's/-/.r/'|sed 's/-/./'
+ cd $_gitname
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
+build() {
+ cd "${_gitname}"
+ rake yasnippet.elc
+ rake yasnippet-debug.elc
+ rake yasnippet-tests.elc #emacs=24.3 tests_Werror=nil
+}
+check() {
+ cd "${_gitname}"
+ rake tests
+}
package () {
- cd $_gitname
- install -d "$pkgdir"/usr/share/emacs/site-lisp/yas
- cp -r * "$pkgdir"/usr/share/emacs/site-lisp/yas
+ cd "${_gitname}"
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/${_gitname}"
+ cp -r * "${pkgdir}/usr/share/emacs/site-lisp/${_gitname}"
}