summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-17 20:11:49 +0200
committersballert2018-09-17 20:11:49 +0200
commit5708d14a4695312da6cdfb437ee827725d46e258 (patch)
treea6fb3b44a21f05be8718f4a7718fb3f95d02debe
downloadaur-5708d14a4695312da6cdfb437ee827725d46e258.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
-rw-r--r--emacs-yasnippet-snippets.install16
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76b931fff743
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = emacs-yasnippet-snippets-git
+ pkgdesc = a collection of yasnippet snippets for many languages
+ pkgver = r661.ef6eae6
+ pkgrel = 1
+ url = https://github.com/AndreaCrotti/yasnippet-snippets
+ install = emacs-yasnippet-snippets.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ depends = emacs-yasnippet
+ provides = emacs-yasnippet-snippets
+ conflicts = emacs-yasnippet-snippets
+ source = git+https://github.com/AndreaCrotti/yasnippet-snippets.git
+ sha256sums = SKIP
+
+pkgname = emacs-yasnippet-snippets-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..79745e89eb0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="AndreaCrotti"
+_gitrepo="yasnippet-snippets"
+
+pkgname=emacs-yasnippet-snippets-git
+pkgver=r661.ef6eae6
+pkgrel=1
+pkgdesc="a collection of yasnippet snippets for many languages"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-yasnippet')
+makedepends=('git')
+provides=('emacs-yasnippet-snippets')
+conflicts=('emacs-yasnippet-snippets')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+install=emacs-yasnippet-snippets.install
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/snippets/"${_gitrepo}"
+ cp -r snippets/* "$pkgdir"/usr/share/emacs/snippets/"${_gitrepo}"
+}
diff --git a/emacs-yasnippet-snippets.install b/emacs-yasnippet-snippets.install
new file mode 100644
index 000000000000..f6014e5caeee
--- /dev/null
+++ b/emacs-yasnippet-snippets.install
@@ -0,0 +1,16 @@
+post_install () {
+
+cat << EOF
+
+==> Add this code to your .emacs file to use the snippets:
+
+
+(add-to-list 'yas-snippet-dirs "/usr/share/emacs/snippets/yasnippet-snippets" t)
+(yas-load-directory "/usr/share/emacs/snippets/yasnippets-snippets" t)
+
+EOF
+}
+
+post_upgrade () {
+ post_install $1
+}