summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinRs2019-04-30 18:07:02 +0800
committerLinRs2019-04-30 18:07:02 +0800
commita9f84d5161f92d6e9068ca2aac767566e6df7d50 (patch)
tree20368c7c7511f1a89c00d4867839b3080b6a84e7
parent5708d14a4695312da6cdfb437ee827725d46e258 (diff)
downloadaur-a9f84d5161f92d6e9068ca2aac767566e6df7d50.tar.gz
upgpkg: emacs-yasnippet-snippets-git 0.11.r0.g69cc1c1-1
- add emacs byte-compile code
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD28
2 files changed, 20 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76b931fff743..c838ec48f078 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-yasnippet-snippets-git
- pkgdesc = a collection of yasnippet snippets for many languages
- pkgver = r661.ef6eae6
+ pkgdesc = Collection of yasnippet snippets for many languages
+ pkgver = 0.11.r0.g69cc1c1
pkgrel = 1
url = https://github.com/AndreaCrotti/yasnippet-snippets
install = emacs-yasnippet-snippets.install
diff --git a/PKGBUILD b/PKGBUILD
index 79745e89eb0b..607eaf148365 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
-# Maintainer: sballert <sballert@posteo.de>
+# Maintainer: LinRs <LinRs at users.noreply.github.com>
+# Contributor: sballert <sballert@posteo.de>
_gituser="AndreaCrotti"
_gitrepo="yasnippet-snippets"
pkgname=emacs-yasnippet-snippets-git
-pkgver=r661.ef6eae6
+pkgver=0.11.r0.g69cc1c1
pkgrel=1
-pkgdesc="a collection of yasnippet snippets for many languages"
+pkgdesc="Collection of yasnippet snippets for many languages"
url="https://github.com/${_gituser}/${_gitrepo}"
arch=('any')
license=('GPL3')
@@ -14,17 +15,24 @@ depends=('emacs' 'emacs-yasnippet')
makedepends=('git')
provides=('emacs-yasnippet-snippets')
conflicts=('emacs-yasnippet-snippets')
-source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+source=("git+${url}.git")
sha256sums=('SKIP')
install=emacs-yasnippet-snippets.install
pkgver() {
- cd "$_gitrepo"
- printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+ cd "$_gitrepo"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+build() {
+ cd "${srcdir}/${_gitrepo}"
+ emacs -q --no-site-file --no-splash -batch -L . -f batch-byte-compile *.el
}
-
package() {
- cd "$_gitrepo"
- install -d "$pkgdir"/usr/share/emacs/snippets/"${_gitrepo}"
- cp -r snippets/* "$pkgdir"/usr/share/emacs/snippets/"${_gitrepo}"
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/snippets/"${_gitrepo}"
+ cp *.el{,c} "${pkgdir}/usr/share/emacs/snippets/${_gitrepo}"
+ cp -r snippets/* "$pkgdir"/usr/share/emacs/snippets/"${_gitrepo}"
}