summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-07-30 02:07:42 +0200
committerhaawda2019-07-30 02:07:42 +0200
commitbeed97032b4594f5ee64987b39c3c0cdfabd0b4d (patch)
tree888ddc76fce02879b8abeb23c2c0bf371453b130
downloadaur-beed97032b4594f5ee64987b39c3c0cdfabd0b4d.tar.gz
initial upload
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65a58378e036
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = emacs-youtube-dl
+ pkgdesc = A youtube-dl download manager for Emacs
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/skeeto/youtube-dl-emacs
+ arch = any
+ license = GPL3
+ depends = emacs
+ depends = emacs-s
+ depends = emacs-dash
+ source = emacs-youtube-dl-1.0.tar.gz::https://github.com/skeeto/youtube-dl-emacs/archive/1.0.tar.gz
+ sha256sums = 4189555f39d9bd3eb288a1e0ae6e77217e63a71ef2c2d4343a7a2ff098f37437
+
+pkgname = emacs-youtube-dl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..571f24629f7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+_pkgsrcname=youtube-dl-emacs
+_pkgmaintainer=skeeto
+pkgver=1.0
+pkgrel=1
+pkgdesc="A youtube-dl download manager for Emacs"
+pkgname=emacs-youtube-dl
+arch=('any')
+url="https://github.com/${_pkgmaintainer}/${_pkgsrcname}"
+license=('GPL3')
+depends=('emacs' 'emacs-s' 'emacs-dash')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/${pkgver}.tar.gz")
+sha256sums=('4189555f39d9bd3eb288a1e0ae6e77217e63a71ef2c2d4343a7a2ff098f37437')
+
+build() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}"/${_pkgsrcname}-${pkgver}
+ mkdir -p "${pkgdir}"/usr/share/emacs/site-lisp/
+ install -m644 *.el{c,} "${pkgdir}"/usr/share/emacs/site-lisp
+}