summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Bourgeois2018-07-15 12:14:46 +0000
committerQuentin Bourgeois2018-07-15 12:14:46 +0000
commit431e9e4b6a85b4a13f94aa63bf556eaf7eaed3f7 (patch)
tree5fbb0bc4c40a67e3b660d1f6f76979c4aa1e504b
downloadaur-431e9e4b6a85b4a13f94aa63bf556eaf7eaed3f7.tar.gz
Initial upload: emacs-zenburn-theme 2.5-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09ce55eadd5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = emacs-zenburn-theme
+ pkgdesc = The Zenburn colour theme ported to Emacs
+ pkgver = 2.5
+ pkgrel = 1
+ url = https://github.com/bbatsov/zenburn-emacs
+ arch = any
+ license = GPL3
+ depends = emacs
+ source = emacs-zenburn-theme-2.5.tar.gz::https://github.com/bbatsov/zenburn-emacs/archive/v2.5.tar.gz
+ sha256sums = f6811eada38ad53e233f53872a0ab9b5264978c7c6cfffef8e88aeb5de876e0e
+
+pkgname = emacs-zenburn-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a3b347ce03c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Quentin Bourgeois <quentin+archlinux@bourgeois.eu>
+
+_upstream_pkgname=zenburn-emacs
+pkgname=emacs-zenburn-theme
+pkgver=2.5
+pkgrel=1
+pkgdesc='The Zenburn colour theme ported to Emacs'
+arch=('any')
+url='https://github.com/bbatsov/zenburn-emacs'
+depends=('emacs')
+license=('GPL3')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/bbatsov/zenburn-emacs/archive/v2.5.tar.gz")
+sha256sums=('f6811eada38ad53e233f53872a0ab9b5264978c7c6cfffef8e88aeb5de876e0e')
+
+package() {
+ cd "${_upstream_pkgname}-${pkgver}"
+
+ install -Dm644 zenburn-theme.el "${pkgdir}/usr/share/emacs/site-lisp/themes/zenburn-theme.el"
+}