summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorP.A. López-Valencia2016-10-28 19:26:55 -0500
committerP.A. López-Valencia2016-10-28 19:26:55 -0500
commit2ddab26674099fc3f0fa7d866898675c073c171f (patch)
treefa33ca2e22a32ff25e9cc2debe89fec3cbc5e147
parent4bc9c11dfc262d34830be0654de892797993098e (diff)
downloadaur-2ddab26674099fc3f0fa7d866898675c073c171f.tar.gz
emacs25-git 25.1.50.125246
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD27
2 files changed, 24 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 870650be8590..29d909188c3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs25-git
pkgdesc = GNU Emacs. Version 25 development and maintenance branch.
- pkgver = 25.1.50.125223
+ pkgver = 25.1.50.125246
pkgrel = 1
url = http://www.gnu.org/software/emacs/
arch = i686
@@ -8,12 +8,11 @@ pkgbase = emacs25-git
license = GPL
makedepends = git
depends = gpm
- depends = giflib
depends = m17n-lib
- depends = desktop-file-utils
depends = alsa-lib
depends = imagemagick
- depends = gtk3
+ depends =
+ depends = webkitgtk
provides = emacs
conflicts = emacs
source = emacs25-git::git://git.savannah.gnu.org/emacs.git#branch=emacs-25
diff --git a/PKGBUILD b/PKGBUILD
index 1c61fe2c0d02..5be0f964a3a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,27 +31,42 @@
#######################################################################
GTK3="YES" # Leave empty to compile with gtk+ 2 support.
LTO= # Enable link-time optimization. Broken.
-CAIRO= # Very broken for me. Use at own risk.
-XWIDGETS= # Use GTK+ native widgets pulled from webkitgtk.
+CAIRO= # Very broken for everyone. Use at own risk.
+XWIDGETS="YES" # Use GTK+ native widgets pulled from webkitgtk.
+ # Experimental as in: It will break and eat your homework.
DOCS_HTML= # Generate and install html documentation.
DOCS_PDF= # Generate and install pdf documentation.
#######################################################################
pkgname=emacs25-git
-pkgver=25.1.50.125223
+pkgver=25.1.50.125246
pkgrel=1
pkgdesc="GNU Emacs. Version 25 development and maintenance branch."
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/emacs/"
license=('GPL')
-depends=('gpm' 'giflib' 'm17n-lib' 'desktop-file-utils' 'alsa-lib' 'imagemagick')
+depends=('gpm' 'm17n-lib' 'alsa-lib' 'imagemagick')
makedepends=('git')
#######################################################################
#######################################################################
-if [[ $GTK3 = "YES" ]]; then depends+=('gtk3'); else depends+=('gtk2'); fi
+if [[ $GTK3 = "YES" ]]; then
+ if [[ $XWIDGETS = "YES" ]];
+ then depends+=('');
+ else depends+=('gtk3'); fi
+ else
+ if [[ $XWIDGETS = "YES" ]];
+ then depends+=('');
+ else depends+=('gtk2');
+ fi
+fi
if [[ $CAIRO = "YES" ]]; then depends+=('cairo'); fi
+if [[ $XWIDGETS = "" ]]; then depends+=('gnutls'); fi
if [[ $XWIDGETS = "YES" ]]; then
- if [[ $GTK3 = "YES" ]]; then depends+=('webkitgtk'); else depends+=('webkitgtk2'); fi
+ if [[ $GTK3 = "YES" ]]; then
+ depends+=('webkitgtk');
+ else
+ depends+=('webkitgtk2');
+ fi
fi
if [[ $DOCS_PDF = "YES" ]]; then makedepends+=('texlive-core'); fi
#######################################################################