summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYichao Zhou2018-07-29 02:35:49 -0700
committerYichao Zhou2018-07-29 02:35:49 -0700
commit2c37e21740906fbde5d122fe5989bc4c4bd6e1c2 (patch)
treea914a1eab67687bf73df430b02f5bf8ec7d47791
parent61a04de8d2ce1633d2223ec5d07e33657fa4babe (diff)
downloadaur-2c37e21740906fbde5d122fe5989bc4c4bd6e1c2.tar.gz
restore emacs26-git
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD318
-rw-r--r--read_this.txt5
3 files changed, 312 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e187296a3c3..c3ba56f169ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,23 @@
pkgbase = emacs26-git
- pkgdesc = GNU Emacs. Emacs 26 development and maintenance branch. Dummy package.
- pkgver = 26.0.90.130767
+ pkgdesc = GNU Emacs. Development.
+ pkgver = 26.1.50.132031
pkgrel = 1
url = http://www.gnu.org/software/emacs/
- arch = i686
arch = x86_64
- license = GPL
- depends = emacs-git
+ license = GPL3
+ makedepends = git
+ depends = alsa-lib
+ depends = gnutls
+ depends = libxml2
+ depends = jansson
+ depends = gtk3
+ depends = libotf
+ depends = libjpeg-turbo
+ depends = giflib
provides = emacs
conflicts = emacs
- source = read_this.txt
- md5sums = 44002f031317f01fea6146d8be5a9b8f
+ source = emacs-git::git+https://github.com/emacs-mirror/emacs.git#branch=emacs-26
+ md5sums = SKIP
pkgname = emacs26-git
diff --git a/PKGBUILD b/PKGBUILD
index 205d3bde9457..917ba4281620 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,309 @@
-# Maintainer: Alejandro López-Valencia <https://aur.archlinux.org/users/vorbote>
+#######################################################################
+# This package is derived from emacs-git. This original maintainer
+# is not willing to support AUR helpers such as yay in emacs-git. This
+# package eases the installation of emacs26-git
+#######################################################################
+#######################################################################
+# Assign "YES" to the variable you want enabled; empty or other value
+# for NO.
+#
+# Where you read experimental, replace with foobar.
+# =================================================
+#
+#######################################################################
+CHECK= # Run tests. May fail, this is developement after all.
+CLANG= # Use clang.
+LTO="YES" # Enable link-time optimization. Experimental.
+CLI= # CLI only binary.
+NOTKIT= # Use no toolkit widgets. Like B&W Twm (001d sk00l).
+ #
+ # Read https://wiki.archlinux.org/index.php/X_resources
+ # https://en.wikipedia.org/wiki/X_resources
+ # and https://www.emacswiki.org/emacs/XftGnuEmacs
+ # for some tips on using outline fonts with
+ # Xft, if you choose no toolkit or Lucid.
+ #
+LUCID= # Use the lucid, a.k.a athena, toolkit. Like XEmacs, sorta.
+GTK2= # GTK2.
+GPM= # Enable gpm support.
+M17N= # Enable m17n international table input support.
+ # You are far better off using UTF-8 and an input
+ # method under X/Wayland. But this gives independence
+ # if you need it.
+OTF="YES" # OTF font support. Also a secondary dependency
+ # by pulling m17n-lib. Not needed in that case.
+CAIRO= # Highly experimental. Maintaner dissapeared.
+XWIDGETS= # Use GTK+ widgets pulled from webkit2gtk. Usable.
+DOCS_HTML= # Generate and install html documentation.
+DOCS_PDF= # Generate and install pdf documentation.
+MAGICK= # Imagemagick 6 libraries support. Imagemagick,
+ # like flash, is bug ridden and won't die; yet useful.
+NOGZ= # Don't compress el files.
+#######################################################################
+
+#######################################################################
pkgname=emacs26-git
-pkgver=26.0.90.130767
+pkgver=26.1.50.132031
pkgrel=1
-pkgdesc="GNU Emacs. Emacs 26 development and maintenance branch. Dummy package."
-arch=('i686' 'x86_64')
+pkgdesc="GNU Emacs. Development."
+arch=('x86_64') # Arch Linux only. Users of derivatives are on their own.
url="http://www.gnu.org/software/emacs/"
-license=('GPL')
-depends=('emacs-git')
+license=('GPL3')
+depends=( 'alsa-lib' 'gnutls' 'libxml2' 'jansson' )
+makedepends=( 'git' )
+
+BRANCH=emacs-26
+
+#######################################################################
+if [[ $CLANG = "YES" ]]; then
+ export CC=/usr/bin/clang ;
+ export CXX=/usr/bin/clang++ ;
+ export CPP="/usr/bin/clang -E" ;
+ export LDFLAGS+=' -fuse-ld=lld' ;
+ makedepends+=( 'clang' 'lld') ;
+fi
+
+if [[ $LTO = "YES" ]]; then
+ export CFLAGS+=" -flto"
+ export tXXFLAGS+=" -flto"
+fi
+
+if [[ $NOTKIT = "YES" ]]; then
+ depends+=( 'dbus' 'hicolor-icon-theme' 'libxinerama' 'libxrandr' 'lcms2' 'librsvg' );
+elif [[ $LUCID = "YES" ]]; then
+ depends+=( 'dbus' 'hicolor-icon-theme' 'libxinerama' 'libxfixes' 'lcms2' 'librsvg' 'xaw3d' );
+elif [[ $GTK2 = "YES" ]]; then
+ depends+=( 'gtk2' );
+else
+ depends+=( 'gtk3' );
+fi
+
+if [[ $GPM = "YES" ]]; then
+ depends+=( 'gpm');
+fi
+
+if [[ $M17N = "YES" ]]; then
+ depends+=( 'm17n-lib' );
+fi
+
+if [[ $OTF = "YES" ]] && [[ ! $M17N = "YES" ]]; then
+ depends+=( 'libotf' );
+fi
+
+if [[ $MAGICK = "YES" ]]; then
+ depends+=( 'libmagick6' 'libjpeg-turbo' 'giflib' );
+elif [[ ! $NOX = "YES" ]]; then
+ depends+=( 'libjpeg-turbo' 'giflib' );
+else
+ depends+=();
+fi
+
+if [[ $CAIRO = "YES" ]]; then
+ depends+=( 'cairo' );
+fi
+
+if [[ $XWIDGETS = "YES" ]]; then
+ if [[ $GTK2 = "YES" ]] || [[ $LUCID = "YES" ]] || [[ $NOTKIT = "YES" ]] || [[ $CLI = "YES" ]]; then
+ echo "";
+ echo "";
+ echo "Xwidgets support *requires* gtk+3!!!";
+ echo "";
+ echo "";
+ exit 1;
+ else
+ depends+=( 'webkit2gtk' );
+ fi
+fi
+
+if [[ $DOCS_PDF = "YES" ]]; then
+ makedepends+=( 'texlive-core' );
+fi
+#######################################################################
+
+#######################################################################
conflicts=('emacs')
provides=('emacs')
-source=('read_this.txt')
-md5sums=('44002f031317f01fea6146d8be5a9b8f')
+source=("emacs-git::git+https://github.com/emacs-mirror/emacs.git#branch=$BRANCH")
+md5sums=('SKIP')
+# If Github access is blocked for reasons, use Savannah's servers instead.
+# Edit the config file of your local repo copy as well.
+#source=("emacs-git::git://git.sv.gnu.org/emacs.git#branch=$BRANCH")
+#source=("emacs-git::git+https://git.savannah.gnu.org/emacs.git#branch=$BRANCH")
+
+if [[ $BRANCH = "master" ]]; then
+ pkgver() {
+ cd "$srcdir/emacs-git"
+
+ printf "%s.%s" \
+ "$(grep AC_INIT configure.ac | \
+ sed -e 's/^.\+\ \([0-9]\+\.[0-9]\+\.[0-9]\+\?\).\+$/\1/')" \
+ "$(git rev-list --count HEAD)"
+ }
+else
+ pkgver() {
+ cd "$srcdir/emacs-git"
+
+ printf "%s.%s" \
+ "$(grep AC_INIT configure.ac | \
+ awk '{split($0,a,","); print a[2]}' | \
+ sed -e 's/\ //g' )" \
+ "$(git rev-list --count HEAD)"
+ }
+fi
+
+# There is no need to run autogen.sh after first checkout.
+# Doing so, breaks incremental compilation.
+prepare() {
+ cd "$srcdir/emacs-git"
+ [[ -x configure ]] || ( ./autogen.sh git && ./autogen.sh autoconf )
+}
+
+build() {
+ cd "$srcdir/emacs-git"
+
+ local _conf=(
+ --prefix=/usr
+ --sysconfdir=/etc
+ --libexecdir=/usr/lib
+ --localstatedir=/var
+ --mandir=/usr/share/man
+ --with-gameuser=:games
+ --with-sound=alsa
+ --with-modules
+# Beware https://debbugs.gnu.org/cgi/bugreport.cgi?bug=25228
+# dconf and gconf break font settings you set in ~/.emacs.
+# If you insist you'll need to play gymnastics with
+# set-frame-font and set-menu-font. Good luck!
+ --without-gconf
+ --without-gsettings
+ )
+
+#######################################################################
+
+#######################################################################
+
+if [[ $CLANG = "YES" ]]; then
+ _conf+=(
+ '--enable-autodepend'
+ );
+fi
+
+if [[ $LTO = "YES" ]]; then
+ _conf+=(
+ '--enable-link-time-optimization'
+ );
+fi
+
+if [[ $CLI = "YES" ]]; then
+ _conf+=( '--without-x' '--with-x-toolkit=no' '--without-xft' '--without-lcms2' '--without-rsvg' );
+elif [[ $NOTKIT = "YES" ]]; then
+ _conf+=( '--with-x-toolkit=no' '--without-toolkit-scroll-bars' '--with-xft' '--without-xaw3d' );
+elif [[ $LUCID = "YES" ]]; then
+ _conf+=( '--with-x-toolkit=lucid' '--with-xft' '--with-xaw3d' );
+elif [[ $GTK2 = "YES" ]]; then
+ _conf+=( '--with-x-toolkit=gtk2' '--without-gsettings' '--without-xaw3d' );
+else
+ _conf+=( '--with-x-toolkit=gtk3' '--without-xaw3d' );
+fi
+
+if [[ ! $GPM = "YES" ]]; then
+ _conf+=( '--without-gpm' );
+fi
+
+if [[ ! $M17N = "YES" ]]; then
+ _conf+=( '--without-m17n-flt' );
+fi
+
+if [[ $MAGICK = "YES" ]]; then
+ _conf+=(
+ '--with-imagemagick'
+ );
+ export PKG_CONFIG_PATH=/usr/lib/imagemagick6/pkgconfig
+else
+ _conf+=( '--without-imagemagick' );
+fi
+
+if [[ $CAIRO = "YES" ]]; then
+ _conf+=( '--with-cairo' );
+fi
+
+if [[ $XWIDGETS = "YES" ]]; then
+ _conf+=( '--with-xwidgets' );
+fi
+
+if [[ $NOGZ = "YES" ]]; then
+ _conf+=( '--without-compress-install' );
+fi
+#######################################################################
+
+#######################################################################
+
+ # Use gold with gcc, unconditionally.
+ #
+ if [[ ! $CLANG = "YES" ]]; then
+ export LD=/usr/bin/ld.gold
+ export LDFLAGS+=" -fuse-ld=gold";
+ fi
+
+ ./configure "${_conf[@]}"
+
+ # Using "make" instead of "make bootstrap" enables incremental
+ # compiling. Less time recompiling. Yay! But you may
+ # need to use bootstrap sometimes to unbreak the build.
+ # Just add it to the command line.
+ #
+ # Please note that incremental compilation implies that you
+ # are reusing your src directory!
+ #
+ make
+
+ # You may need to run this if 'loaddefs.el' files corrupt.
+ #cd "$srcdir/emacs-git/lisp"
+ #make autoloads
+ #cd ../
+
+ # Optional documentation formats.
+ if [[ $DOCS_HTML = "YES" ]]; then
+ make html;
+ fi
+ if [[ $DOCS_PDF = "YES" ]]; then
+ make pdf;
+ fi
+ if [[ $CHECK = "YES" ]]; then
+ make check;
+ fi
+
+}
package() {
- echo ""
- echo ""
- echo ""
- echo ""
- echo ""
- echo "Please use emacs-git, using the option to track "
- echo "the emacs-26 branch."
- echo ""
- echo ""
- echo ""
- echo ""
- exit 1
+ cd "$srcdir/emacs-git"
+
+ make DESTDIR="$pkgdir/" install
+
+ # Install optional documentation formats
+ if [[ $DOCS_HTML = "YES" ]]; then make DESTDIR="$pkgdir/" install-html; fi
+ if [[ $DOCS_PDF = "YES" ]]; then make DESTDIR="$pkgdir/" install-pdf; fi
+
+ # remove conflict with ctags package
+ mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
+
+ if [[ $NOGZ = "YES" ]]; then
+ mv "$pkgdir"/usr/share/man/man1/{ctags.1,ctags.emacs.1};
+ else
+ mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1.gz}
+ fi
+
+ # fix user/root permissions on usr/share files
+ find "$pkgdir"/usr/share/emacs/ | xargs chown root:root
+
+ # fix permssions on /var/games
+ mkdir -p "$pkgdir"/var/games/emacs
+ chmod 775 "$pkgdir"/var/games
+ chmod 775 "$pkgdir"/var/games/emacs
+ chown -R root:games "$pkgdir"/var/games
+
}
# vim:set ft=sh ts=2 sw=2 et:
+
diff --git a/read_this.txt b/read_this.txt
deleted file mode 100644
index dd4c21163775..000000000000
--- a/read_this.txt
+++ /dev/null
@@ -1,5 +0,0 @@
-This is a dummy package. If you want to track the maintenance branch for
-Emacs 26, you can do it using the PKGBUILD of emacs-git. It lightens my
-load and gives you a better maintained PKGBUILD.
-
-TL;DR: use emacs-git.