summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro López-Valencia2017-10-13 11:07:38 -0500
committerAlejandro López-Valencia2017-10-13 11:07:38 -0500
commit6f2b615aa3b2ec69eda687fd7d654f73a1113a65 (patch)
treefd756824084b9269c0ef5f8efdea335291ad9fd6
parent7ae58e697879b4666efa6bee9acf68d826f2e8c0 (diff)
downloadaur-6f2b615aa3b2ec69eda687fd7d654f73a1113a65.tar.gz
Do a temp warning before killing of this package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD152
-rw-r--r--read_this.txt5
3 files changed, 18 insertions, 155 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f031f80b9573..054205e788ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,15 @@
pkgbase = emacs26-git
- pkgdesc = GNU Emacs. Emacs 26 development and maintenance branch.
- pkgver = 25.1.50.r127001
+ pkgdesc = GNU Emacs. Emacs 26 development and maintenance branch. Dummy package.
+ pkgver = 26.0.90.130765
pkgrel = 1
url = http://www.gnu.org/software/emacs/
arch = i686
arch = x86_64
license = GPL
- makedepends = git
- depends = gpm
- depends = giflib
- depends = m17n-lib
- depends = desktop-file-utils
- depends = alsa-lib
- depends = imagemagick
- depends = gtk3
+ depends = emacs-git
provides = emacs
conflicts = emacs
- source = emacs-git::git://git.savannah.gnu.org/emacs.git
- md5sums = SKIP
+ source = read_this.txt
pkgname = emacs26-git
diff --git a/PKGBUILD b/PKGBUILD
index 5d6c8cccbbc9..72410fe8199f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,156 +1,22 @@
-# Maintainer: Pedro A. López-Valencia <https://aur.archlinux.org/users/vorbote>
-
-#######################################################################
-# CAVEAT LECTOR
-#######################################################################
-#
-# Don't run this on a tmpfs unless you have oodles of RAM.
-# When the official git repo started, the size was about
-# 200MB. As time passes, it is growing more and more.
-# Final directory size after a build is shy of 1Gb!
-# Furthermore, the FSF isn't precisely rich and Savannah
-# network costs aren't cheap. Keep your git checkout!
-#
-# Keeping this directory in a safe place preserves the
-# git repo and the src dir for faster compilation if
-# you want. You may delete the pkg dir after successfully
-# creating a package.
-#
-# "makepkg -i" is your friend.
-#
-#######################################################################
-
-#######################################################################
-#
-# Still reading? Here kid, have enough rope to hang yourself. :-)
-#
-#######################################################################
-
-#######################################################################
-# Assign "YES" to the variable you want enabled, empty otherwise
-#######################################################################
-GTK3="YES" # Leave empty to compile with gtk+ 2 support.
-LTO= # Enable link-time optimization. Broken.
-CAIRO= # Very broken for me. Use at own risk.
-XWIDGETS= # Use GTK+ native widgets pulled from webkitgtk.
-DOCS_HTML= # Generate and install html documentation.
-DOCS_PDF= # Generate and install pdf documentation.
-#######################################################################
+# Maintainer: Alejandro López-Valencia <https://aur.archlinux.org/users/vorbote>
pkgname=emacs26-git
-pkgver=25.1.50.r127002
+pkgver=26.0.90.130765
pkgrel=1
-pkgdesc="GNU Emacs. Emacs 26 development and maintenance branch."
+pkgdesc="GNU Emacs. Emacs 26 development and maintenance branch. Dummy package."
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/emacs/"
license=('GPL')
-depends=('gpm' 'giflib' 'm17n-lib' 'desktop-file-utils' 'alsa-lib' 'imagemagick')
-makedepends=('git')
-#######################################################################
-#######################################################################
-if [[ $GTK3 = "YES" ]]; then depends+=('gtk3'); else depends+=('gtk2'); fi
-if [[ $CAIRO = "YES" ]]; then depends+=('cairo'); fi
-if [[ $XWIDGETS = "YES" ]]; then
- if [[ $GTK3 = "YES" ]]; then depends+=('webkitgtk'); else depends+=('webkitgtk2'); fi
-fi
-if [[ $DOCS_PDF = "YES" ]]; then makedepends+=('texlive-core'); fi
-#######################################################################
-#######################################################################
+depends=('emacs-git')
conflicts=('emacs')
provides=('emacs')
-source=("$pkgname::git://git.savannah.gnu.org/emacs.git#branch=emacs-26")
-#source=("$pkgname::git+http://git.savannah.gnu.org/r/emacs.git#branch=emacs-26")
-md5sums=('SKIP')
-
-pkgver() {
- cd "$srcdir/$pkgname"
- printf "%s.r%s" \
- "$(grep AC_INIT configure.ac | \
- sed -e 's/^.\+\ \([0-9]\+\.[0-9]\+\.[0-9]\+\).\+$/\1/')" \
- "$(git rev-list --count HEAD)"
-}
-
-
-# There is no need to run autogen.sh after first checkout.
-# Doing so, breaks incremental compilation.
-prepare() {
- cd "$srcdir/$pkgname"
-
- [[ -x configure ]] || ./autogen.sh
-}
-
-build() {
- cd "$srcdir/$pkgname"
-
- # Avoid hardening-wrapper (taken from emacs-pretest, thanks to Thomas Jost).
- export PATH=$(echo "$PATH" | sed 's!/usr/lib/hardening-wrapper/bin!!g')
-
- local _conf=(
- --prefix=/usr
- --sysconfdir=/etc
- --libexecdir=/usr/lib
- --localstatedir=/var
- --mandir=/usr/share/man
- --with-gameuser=:games
- --with-sound=alsa
- --with-xft
- --with-modules)
-
-#######################################################################
-#######################################################################
- if [[ $GTK3 = "YES" ]]; then
- _conf+=('--with-x-toolkit=gtk3' '--without-gconf' '--with-gsettings');
- else
- _conf+=('--with-x-toolkit=gtk2' '--with-gconf' '--without-gsettings');
- fi
- if [[ $LTO = "YES" ]]; then _conf+=('--enable-link-time-optimization'); fi
- if [[ $CAIRO = "YES" ]]; then _conf+=('--with-cairo'); fi
- if [[ $XWIDGETS = "YES" ]]; then _conf+=('--with-xwidgets'); fi
-#######################################################################
-#######################################################################
-
- ./configure "${_conf[@]}"
-
- # Using "make" instead of "make bootstrap" enables incremental
- # compiling. Less time recompiling. Yay! But if you may
- # need to use bootstrap sometime, just add it to the command
- # line.
- # Please note that incremental compilation implies that you
- # are reusing your src directory!
- make
-
- # You may need to run this if loaddefs.el files become
- # corrupt.
- #cd "$srcdir/$pkgname/lisp"
- #make autoloads
- #cd ../
-
- # Optional documentation formats.
- if [[ $DOCS_HTML = "YES" ]]; then make html; fi
- if [[ $DOCS_PDF = "YES" ]]; then make pdf; fi
-}
+source=('read_this.txt')
+md5sums=('')
package() {
- cd "$srcdir/$pkgname"
-
- make DESTDIR="$pkgdir/" install
-
- # Install optional documentation formats
- if [[ $DOCS_HTML = "YES" ]]; then make DESTDIR="$pkgdir/" install-html; fi
- if [[ $DOCS_PDF = "YES" ]]; then make DESTDIR="$pkgdir/" install-pdf; fi
-
- # remove conflict with ctags package
- mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
- mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1.gz}
-
- # fix user/root permissions on usr/share files
- find "$pkgdir"/usr/share/emacs/ | xargs chown root:root
-
- # fix permssions on /var/games
- mkdir -p "$pkgdir"/var/games/emacs
- chmod 775 "$pkgdir"/var/games
- chmod 775 "$pkgdir"/var/games/emacs
- chown -R root:games "$pkgdir"/var/games
+ echo "Please use emacs-git, using the option to track "
+ echo "the emacs-26 branch."
+ exit 1
}
# vim:set ft=sh ts=2 sw=2 et:
diff --git a/read_this.txt b/read_this.txt
new file mode 100644
index 000000000000..dd4c21163775
--- /dev/null
+++ b/read_this.txt
@@ -0,0 +1,5 @@
+This is a dummy package. If you want to track the maintenance branch for
+Emacs 26, you can do it using the PKGBUILD of emacs-git. It lightens my
+load and gives you a better maintained PKGBUILD.
+
+TL;DR: use emacs-git.