summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro López-Valencia2017-12-27 17:22:51 -0500
committerAlejandro López-Valencia2017-12-27 17:22:51 -0500
commit277bc449cb175a5a91360e762276d049c8f9b2c3 (patch)
tree9ae7af6568d902df926b36d9f7dbfeeae3c430bb
parent9e83b233002c8b3ba106daec5ba0ff1aaeb03107 (diff)
downloadaur-277bc449cb175a5a91360e762276d049c8f9b2c3.tar.gz
emacs-git 27.0.50.131638-1
Finally make using the Athena toolkit possible.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD32
2 files changed, 14 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6831dba4558..08e5989736ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Development.
- pkgver = 27.0.50.131377
+ pkgver = 27.0.50.131638
pkgrel = 1
url = http://www.gnu.org/software/emacs/
arch = x86_64
license = GPL3
makedepends = git
depends = alsa-lib
- depends = gtk3
+ depends = libxaw
depends = libotf
depends = libjpeg-turbo
depends = giflib
diff --git a/PKGBUILD b/PKGBUILD
index 7af6afdec35f..ef33c50399c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,12 +36,12 @@ BRANCH=master
# =================================================
#
#######################################################################
+CHECK= # Run tests.
CLANG= # Use clang.
LTO= # Enable link-time optimization. Experimental.
-#ATHENA= # Use Athena widgets. (83 1337, 83 001d sk00l).
+ATHENA= # Use Athena widgets. (83 1337, 83 001d sk00l).
GTK2= # Leave empty to compile with GTK+ 3 support.
# No, GTK+ 2 ain't kool, dawg!
-NOGTK3= # Leave empty to compile with GTK+ 3 support.
GPM= # Enable gpm support.
M17N= # Enable m17n international table input support.
# You are far better off using UTF-8 and an input
@@ -64,7 +64,7 @@ if [[ BRANCH = "emacs-26" ]]; then
else
pkgname=emacs-git
fi
-pkgver=27.0.50.131377
+pkgver=27.0.50.131638
pkgrel=1
pkgdesc="GNU Emacs. Development."
arch=('x86_64') # Arch Linux only. Users of derivatives are on their own.
@@ -90,14 +90,10 @@ fi
if [[ $ATHENA = "YES" ]]; then
depends+=( 'libxaw' );
-fi
-
-if [[ $GTK2 = "YES" ]]; then
+elif [[ $GTK2 = "YES" ]]; then
depends+=( 'gtk2' );
else
- if [[ ! $NOGTK3 = "YES" ]]; then
- depends+=( 'gtk3' );
- fi
+ depends+=( 'gtk3' );
fi
if [[ $GPM = "YES" ]]; then
@@ -199,23 +195,15 @@ if [[ $LTO = "YES" ]]; then
);
fi
-if [[ $ATHENA = "YES" ]]; then
- _conf+=(
- '--with-x-toolkit=athena'
- '--without-gconf'
- '--without-gsettings'
- );
-fi
-
# Beware https://debbugs.gnu.org/cgi/bugreport.cgi?bug=25228
# dconf and gconf break font settings you set in ~/.emacs.
# If you insist you'll need to play gymnastics with
# set-frame-font and set-menu-font. Good luck!
-if [[ $GTK2 = "YES" ]]; then
- #_conf+=( '--with-x-toolkit=gtk2' '--with-gconf' '--without-gsettings' );
+if [[ $ATHENA = "YES" ]]; then
+ _conf+=( '--with-x-toolkit=athena' '--without-gconf' '--without-gsettings' );
+elif [[ $GTK2 = "YES" ]]; then
_conf+=( '--with-x-toolkit=gtk2' '--without-gconf' '--without-gsettings' );
else
- #_conf+=( '--with-x-toolkit=gtk3' '--without-gconf' '--with-gsettings' );
_conf+=( '--with-x-toolkit=gtk3' '--without-gconf' '--without-gsettings' );
fi
@@ -281,6 +269,10 @@ fi
if [[ $DOCS_PDF = "YES" ]]; then
make pdf;
fi
+ if [[ $CHECK = "YES" ]]; then
+ make check;
+ fi
+
}
package() {