summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2019-10-22 20:27:35 +0000
committerPedro A. López-Valencia2019-10-22 20:27:35 +0000
commit6eab19e19f468a40591c41b3c1124aa623094350 (patch)
treed239b5db6e17974fe2b67fa6ffb0983bc4c8b605
parent4f86f98ee492305ad47bef7e1d375aab03bbece0 (diff)
downloadaur-6eab19e19f468a40591c41b3c1124aa623094350.tar.gz
Don't assume people use parallel make. Drop -flto=jobserver
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed8f0e2e466b..5412ce21e162 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Development.
- pkgver = 27.0.50.138368
+ pkgver = 27.0.50.139156
pkgrel = 1
url = http://www.gnu.org/software/emacs/
arch = x86_64
license = GPL3
makedepends = git
+ makedepends = clang
+ makedepends = lld
depends = alsa-lib
depends = gnutls
depends = libxml2
diff --git a/PKGBUILD b/PKGBUILD
index a48652728a59..a3db475b0edc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@
#
################################################################################
CHECK= # Run tests. May fail, this is developement after all.
-CLANG= # Use clang.
+CLANG="YES" # Use clang.
LTO="YES" # Enable link-time optimization. Not that experimental anymore.
# Seems fixed in GCC, so I've reenabled binutils support, please
# report any bug, to make it use clang by default again.
@@ -58,7 +58,7 @@ NOGZ="YES" # Don't compress .el files.
################################################################################
pkgname="emacs-git"
-pkgver=27.0.50.138368
+pkgver=27.0.50.139156
pkgrel=1
pkgdesc="GNU Emacs. Development."
arch=('x86_64') # Arch Linux only. Derivative users are on their own.
@@ -80,8 +80,8 @@ md5sums=('SKIP')
################################################################################
if [[ $LTO = "YES" ]]; then
- CFLAGS+=" -flto=jobserver -fuse-linker-plugin"
- CXXFLAGS+=" -flto=jobserver -fuse-linker-plugin"
+ CFLAGS+=" -flto -fuse-linker-plugin"
+ CXXFLAGS+=" -flto -fuse-linker-plugin"
fi
if [[ $CLANG = "YES" ]]; then