summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2021-04-11 11:24:39 -0500
committerPedro A. López-Valencia2021-04-11 11:24:39 -0500
commit1a49b74f7e1e58daca5bbb61e5bdf9ae0855318d (patch)
tree0cdd23e91bafa61cf72c85a96e15932316d3a7af
parent166e4fe39b49f74813065b9427b2452e1df214c1 (diff)
downloadaur-1a49b74f7e1e58daca5bbb61e5bdf9ae0855318d.tar.gz
* Fix libgccjit dependency generation for cli compiles. Hopefully this is the last fix.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5b8617aea5c..4d5d4df4dc15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Development master branch.
- pkgver = 28.0.50.146289
+ pkgver = 28.0.50.146296
pkgrel = 1
url = http://www.gnu.org/software/emacs/
arch = x86_64
@@ -15,6 +15,7 @@ pkgbase = emacs-git
depends = m17n-lib
depends = libotf
depends = harfbuzz
+ depends = libgccjit
depends = gtk3
depends = libjpeg-turbo
depends = giflib
diff --git a/PKGBUILD b/PKGBUILD
index 79610e0eb9ee..662e600b62ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -53,7 +53,7 @@ if [[ $CLI == "YES" ]] ; then
else
pkgname="emacs-git"
fi
-pkgver=28.0.50.146289
+pkgver=28.0.50.146296
pkgrel=1
pkgdesc="GNU Emacs. Development master branch."
arch=('x86_64')
@@ -108,6 +108,12 @@ else
fi
if [[ $CLI == "YES" ]]; then
+ depends_nox+=( 'libgccjit' );
+else
+ depends+=( 'libgccjit' );
+fi
+
+if [[ $CLI == "YES" ]]; then
depends=("${depends_nox[@]}");
elif [[ $NOTKIT == "YES" ]]; then
depends+=( 'dbus' 'hicolor-icon-theme' 'libxinerama' 'libxrandr' 'lcms2' 'librsvg' 'libxfixes' );
@@ -211,7 +217,6 @@ fi
if [[ $JIT == "YES" ]]; then
_conf+=( '--with-native-compilation' );
- depends+=( 'libgccjit' );
fi
if [[ $CLI == "YES" ]]; then