summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2021-04-25 20:24:37 +0000
committerPedro A. López-Valencia2021-04-25 20:24:37 +0000
commite065d2a6c2cc1da1ff0faca0af78a4d89789e21f (patch)
tree0a57c35909c9b8744db94d7aa99fdace61fb9872
parent01f2968b0ef043bbce9a2c740870c9561c076540 (diff)
downloadaur-e065d2a6c2cc1da1ff0faca0af78a4d89789e21f.tar.gz
* feature/native-comp merged into master.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be0d050e3617..069426fd6479 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Development master branch.
- pkgver = 28.0.50.146315
+ pkgver = 28.0.50.148045
pkgrel = 1
url = http://www.gnu.org/software/emacs/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 1fe96e8b0b4b..06d1ba44f0c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,6 +26,12 @@ GOLD= # Use the gold linker.
LTO="YES" # Enable link-time optimization. Read emacs's INSTALL before
# attempting to use it with clang.
JIT= # Enable native just-in-time compilation. libgccjit is in AUR.
+ # This compiles only performance critical elisp files.
+ # To compile all elisp on demand, set
+ # comp-deferred-compilation non-nil
+AOT= # Precompile all included elisp. It takes a long time.
+ # You still need to enable on-demand compilation
+ # for your own packages.
CLI= # CLI only binary.
NOTKIT= # Use no toolkit widgets. Like B&W Twm (001d sk00l).
LUCID= # Use the lucid, a.k.a athena, toolkit. Like XEmacs, sorta.
@@ -53,7 +59,7 @@ if [[ $CLI == "YES" ]] ; then
else
pkgname="emacs-git"
fi
-pkgver=28.0.50.146315
+pkgver=28.0.50.148045
pkgrel=1
pkgdesc="GNU Emacs. Development master branch."
arch=('x86_64')
@@ -66,7 +72,7 @@ provides=('emacs' 'emacs26-git' 'emacs-27-git' 'emacs-seq' 'emacs-nox')
conflicts=('emacs' 'emacs26-git' 'emacs-27-git' 'emacs-seq' 'emacs-nox')
replaces=('emacs' 'emacs26-git' 'emacs-27-git' 'emacs-seq' 'emacs-nox')
source=("emacs-git::git://git.savannah.gnu.org/emacs.git")
-# I've given up on Savannah for the time being. A shame...
+# If Savannah fails for reasons, use Github's mirror
#source=("emacs-git::git://github.com/emacs-mirror/emacs.git")
options=(!strip)
b2sums=('SKIP')
@@ -268,7 +274,11 @@ _conf+=('--program-transform-name=s/\([ec]tags\)/\1.emacs/')
# Please note that incremental compilation implies that you
# are reusing your src directory!
#
- make
+ if [[ $JIT == "YES" ]] && [[ $AOT == "YES" ]]; then
+ make NATIVE_FULL_AOT=1
+ else
+ make
+ fi
# You may need to run this if 'loaddefs.el' files become corrupt.
#cd "$srcdir/emacs-git/lisp"