summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2021-12-05 10:03:44 -0500
committerPedro A. López-Valencia2021-12-05 10:03:44 -0500
commit06536033e7d0aeb17ffef5dd5d3d617f6b76dfc3 (patch)
tree1922433e7da6a811741b8bb0143046c7e26c789d
parentaafd23029a6ed2033cde43bb78b82223af439d5d (diff)
downloadaur-06536033e7d0aeb17ffef5dd5d3d617f6b76dfc3.tar.gz
* 29.0.50.152394
* Integrate patches by zhenya1007. Make optional both Linux console mouse support and sound ALSA support.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD42
2 files changed, 38 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d8bfa5b146c..89d78b53b3f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Development master branch.
- pkgver = 29.0.50.152360
+ pkgver = 29.0.50.152394
pkgrel = 1
url = http://www.gnu.org/software/emacs/
install = emacs-git.install
@@ -8,14 +8,11 @@ pkgbase = emacs-git
license = GPL3
makedepends = git
makedepends = xorgproto
- depends = alsa-lib
depends = gnutls
depends = libxml2
depends = jansson
- depends = gpm
depends = harfbuzz
depends = gtk3
- depends = libxpm
depends = libjpeg-turbo
depends = giflib
depends = cairo
diff --git a/PKGBUILD b/PKGBUILD
index 7f1b866bbd2e..93d9fe0296e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -41,6 +41,8 @@ AOT= # Precompile all included elisp. It takes a long time.
CLI= # CLI only binary.
+GPM= # Mouse support in Linux console using gmpd.
+
NOTKIT= # Use no toolkit widgets. Like B&W Twm (001d sk00l).
# Bitmap fonts only, 1337!
@@ -53,6 +55,8 @@ LUCID= # Use the lucid, a.k.a athena, toolkit. Like XEmacs, sorta.
# Xft, if you choose no toolkit or Lucid.
#
+ALSA= # Linux sound support.
+
NOCAIRO= # Disable here.
XWIDGETS= # Use GTK+ widgets pulled from webkit2gtk. Usable.
@@ -70,13 +74,13 @@ if [[ $CLI == "YES" ]] ; then
else
pkgname="emacs-git"
fi
-pkgver=29.0.50.152360
+pkgver=29.0.50.152394
pkgrel=1
pkgdesc="GNU Emacs. Development master branch."
arch=('x86_64')
url="http://www.gnu.org/software/emacs/"
license=('GPL3')
-depends_nox=('alsa-lib' 'gnutls' 'libxml2' 'jansson' 'gpm')
+depends_nox=('gnutls' 'libxml2' 'jansson')
depends=("${depends_nox[@]}" 'harfbuzz')
makedepends=('git')
provides=('emacs' 'emacs26-git' 'emacs-27-git' 'emacs28-git' 'emacs-seq' 'emacs-nox')
@@ -126,13 +130,13 @@ fi
if [[ $CLI == "YES" ]]; then
depends=("${depends_nox[@]}");
elif [[ $NOTKIT == "YES" ]]; then
- depends+=( 'dbus' 'hicolor-icon-theme' 'libxinerama' 'libxrandr' 'lcms2' 'librsvg' 'libxfixes' 'libxpm' );
+ depends+=( 'dbus' 'hicolor-icon-theme' 'libxinerama' 'libxrandr' 'lcms2' 'librsvg' 'libxfixes' );
makedepends+=( 'xorgproto' );
elif [[ $LUCID == "YES" ]]; then
- depends+=( 'dbus' 'hicolor-icon-theme' 'libxinerama' 'libxfixes' 'lcms2' 'librsvg' 'xaw3d' 'libxrandr' 'libxpm' );
+ depends+=( 'dbus' 'hicolor-icon-theme' 'libxinerama' 'libxfixes' 'lcms2' 'librsvg' 'xaw3d' 'libxrandr' );
makedepends+=( 'xorgproto' );
else
- depends+=( 'gtk3' 'libxpm' );
+ depends+=( 'gtk3' );
makedepends+=( 'xorgproto' );
fi
@@ -142,6 +146,14 @@ elif [[ $CLI == "YES" ]]; then
depends+=();
fi
+if [[ $ALSA == "YES" ]]; then
+ if [[ $CLI == "YES" ]]; then
+ depends_nox+=( 'alsa-lib' );
+ else
+ depends+=( 'alsa-lib' );
+ fi
+fi
+
if [[ ! $NOCAIRO == "YES" ]] && [[ ! $CLI == "YES" ]] ; then
depends+=( 'cairo' );
fi
@@ -159,6 +171,14 @@ if [[ $XWIDGETS == "YES" ]]; then
fi
fi
+if [[ $GPM == "YES" ]]; then
+ if [[ $CLI == "YES" ]]; then
+ depends_nox+=( 'gpm' );
+ else
+ depends+=( 'gpm' );
+ fi
+fi
+
if [[ $DOCS_PDF == "YES" ]]; then
makedepends+=( 'texlive-core' );
fi
@@ -240,10 +260,22 @@ if [[ $NOCAIRO == "YES" || $CLI == "YES" ]]; then
_conf+=( '--without-cairo' );
fi
+if [[ $SOUND == "YES" ]]; then
+ _conf+=( '--with-sound=alsa' );
+else
+ _conf+=( '--with-sound=no' );
+fi
+
if [[ $XWIDGETS == "YES" ]]; then
_conf+=( '--with-xwidgets' );
fi
+if [[ $GPM == "YES" ]]; then
+ true
+else
+ _conf+=( '--without-gpm' );
+fi
+
if [[ $NOGZ == "YES" ]]; then
_conf+=( '--without-compress-install' );
fi