summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2022-06-03 16:54:39 -0500
committerPedro A. López-Valencia2022-06-03 16:54:39 -0500
commit18b6caa302e530dbd6712aad0d3d314810443188 (patch)
tree299762844527155f6051843a9674464c894747a5
parent5123a3741e482f9110fd25a02a93cd56706fcbfd (diff)
downloadaur-18b6caa302e530dbd6712aad0d3d314810443188.tar.gz
* 29.0.50.156996-4
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
-rwxr-xr-xnemacs7
3 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71d6122e43d5..0fe4bc25047c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Development master branch.
pkgver = 29.0.50.156996
- pkgrel = 3
+ pkgrel = 4
url = http://www.gnu.org/software/emacs/
install = emacs-git.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 65ecff084a52..56f784d1a974 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -79,7 +79,7 @@ else
pkgname="emacs-git"
fi
pkgver=29.0.50.156996
-pkgrel=3
+pkgrel=4
pkgdesc="GNU Emacs. Development master branch."
arch=('x86_64')
url="http://www.gnu.org/software/emacs/"
@@ -89,11 +89,13 @@ depends=("${depends_nox[@]}" 'harfbuzz')
makedepends=('git')
provides=('emacs')
replaces=('emacs')
-#source=("emacs-git::git://git.savannah.gnu.org/emacs.git")
-source=("emacs-git::git+https://git.savannah.gnu.org/git/emacs.git")
+#source=("emacs-git::git://git.savannah.gnu.org/emacs.git"
+source=("emacs-git::git+https://git.savannah.gnu.org/git/emacs.git"
+ "nemacs")
options=(!strip)
install=emacs-git.install
-b2sums=('SKIP')
+b2sums=('SKIP'
+ '58e028b439d3c7cf03ea0be617b429a2c54e7aa1b8ca32b5ed489214daaa71e22c323de9662761ad2ce4de58e21dbe45ce6ce198f402686828574f8043d053d0')
################################################################################
################################################################################
@@ -342,6 +344,10 @@ package() {
make DESTDIR="$pkgdir/" install
+ install -d -m 755 "$srcdir"/nemacs "$pkgdir"/usr/bin
+
+ #if [[ ! $CLI == "YES" ]]; then
+
# Install optional documentation formats
if [[ $DOCS_HTML == "YES" ]]; then make DESTDIR="$pkgdir/" install-html; fi
if [[ $DOCS_PDF == "YES" ]]; then make DESTDIR="$pkgdir/" install-pdf; fi
diff --git a/nemacs b/nemacs
new file mode 100755
index 000000000000..6becea07654c
--- /dev/null
+++ b/nemacs
@@ -0,0 +1,7 @@
+#!/usr/bin/bash -e
+
+# Hi there, if you need to use emacs in a console, but compile the
+# gui version, this is for your.
+
+[[ -x /usr/bin/emacs ]] && /usr/bin/emacs -nw $*
+