summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2022-06-03 13:19:47 -0500
committerPedro A. López-Valencia2022-06-03 13:27:55 -0500
commit471c2003e4bcdd16ec97eb16b722a6379b828cc2 (patch)
tree0cdf833e5c6ce96aee2cbabab4b8860c500cf4cf
parent9ed490b2daf05a855b920b9ac91336c4861b78db (diff)
downloadaur-471c2003e4bcdd16ec97eb16b722a6379b828cc2.tar.gz
* Drop AOT flag. There is no NATIVE_FULL compilation support anymore.
-rw-r--r--PKGBUILD11
1 files changed, 2 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f534ec1d9a80..e4346dcb78eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,10 +35,6 @@ JIT="YES" # Enable native just-in-time compilation. libgccjit is in AUR.
# (setq comp-deferred-compilation t)
# to your .emacs file.
-AOT= # Precompile all included elisp. It takes a long time.
- # You still need to enable on-demand compilation
- # for your own packages.
-
CLI= # CLI only binary.
GPM= # Mouse support in Linux console using gpmd.
@@ -319,11 +315,8 @@ _conf+=('--program-transform-name=s/\([ec]tags\)/\1.emacs/')
# Please note that incremental compilation implies that you
# are reusing your src directory!
#
- if [[ $JIT == "YES" ]] && [[ $AOT == "YES" ]]; then
- make NATIVE_FULL_AOT=1
- else
- make
- fi
+
+ make
# You may need to run this if 'loaddefs.el' files become corrupt.
#cd "$srcdir/emacs-git/lisp"