summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2022-03-06 11:31:31 -0500
committerPedro A. López-Valencia2022-03-06 11:31:31 -0500
commit475f6d1121f8acaaf03444e5693e5d2e3075690d (patch)
tree6f3f4ad64ad0d5db256de05d52e841c681cc4055
parent573ea527918299d3e8aa02137b980bd4ee15f28e (diff)
downloadaur-475f6d1121f8acaaf03444e5693e5d2e3075690d.tar.gz
* Revert to using GTK3 instead of PGTK. Menus are broken these days.
* Add a couple of new X library dependencies.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c0e85935cb1..ad4cae3b9d0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Development master branch.
- pkgver = 29.0.50.153989
+ pkgver = 29.0.50.154805
pkgrel = 1
url = http://www.gnu.org/software/emacs/
install = emacs-git.install
@@ -16,8 +16,12 @@ pkgbase = emacs-git
depends = libgccjit
depends = libxi
depends = gtk3
+ depends = libsm
+ depends = xcb-util
+ depends = libxcb
depends = libjpeg-turbo
depends = giflib
+ depends = cairo
provides = emacs
provides = emacs-pretest
provides = emacs26-git
diff --git a/PKGBUILD b/PKGBUILD
index 860d361361c9..059daa7300de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -46,9 +46,10 @@ GPM= # Mouse support in Linux console using gpmd.
NOTKIT= # Use no toolkit widgets. Like B&W Twm (001d sk00l).
# Bitmap fonts only, 1337!
-PGTK="YES" # Use native GTK3 build. Supports Wayland, yay!
+PGTK= # Use native GTK3 build. Supports Wayland, yay!
+ # Menus are broken as of 2022-03-06 when I compiled a new copy..
-GTK3= # The new GTK2. Really, why would you?
+GTK3="YES" # GTK3 old windowing interface.
LUCID= # Use the lucid, a.k.a athena, toolkit. Like XEmacs, sorta.
#
@@ -80,7 +81,7 @@ if [[ $CLI == "YES" ]] ; then
else
pkgname="emacs-git"
fi
-pkgver=29.0.50.153989
+pkgver=29.0.50.154805
pkgrel=1
pkgdesc="GNU Emacs. Development master branch."
arch=('x86_64')
@@ -138,16 +139,16 @@ fi
if [[ $CLI == "YES" ]]; then
depends=("${depends_nox[@]}");
elif [[ $NOTKIT == "YES" ]]; then
- depends+=( 'dbus' 'hicolor-icon-theme' 'libxinerama' 'libxrandr' 'lcms2' 'librsvg' 'libxfixes' 'libxi' );
+ depends+=( 'dbus' 'hicolor-icon-theme' 'libxinerama' 'libxrandr' 'lcms2' 'librsvg' 'libxfixes' 'libxi' 'libsm' 'xcb-util' 'libxcb' );
makedepends+=( 'xorgproto' );
elif [[ $LUCID == "YES" ]]; then
- depends+=( 'dbus' 'hicolor-icon-theme' 'libxinerama' 'libxfixes' 'lcms2' 'librsvg' 'xaw3d' 'libxrandr' 'libxi' );
+ depends+=( 'dbus' 'hicolor-icon-theme' 'libxinerama' 'libxfixes' 'lcms2' 'librsvg' 'xaw3d' 'libxrandr' 'libxi' 'libsm' 'xcb-util' 'libxcb' );
makedepends+=( 'xorgproto' );
elif [[ $GTK3 == "YES" ]]; then
- depends+=( 'gtk3' );
+ depends+=( 'gtk3' 'libsm' 'xcb-util' 'libxcb' );
makedepends+=( 'xorgproto' 'libxi' );
elif [[ $PGTK == "YES" ]]; then
- depends+=( 'gtk3' );
+ depends+=( 'gtk3' 'libsm' 'xcb-util' 'libxcb' );
makedepends+=( 'xorgproto' 'libxi' );
fi