summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2022-06-03 16:15:30 -0500
committerPedro A. López-Valencia2022-06-03 16:15:30 -0500
commit5123a3741e482f9110fd25a02a93cd56706fcbfd (patch)
tree1130278690899eb9e148ed3b2240ab0293b8a9fc
parent364c217d75e2d4144c2d71efe9f11826117834a1 (diff)
downloadaur-5123a3741e482f9110fd25a02a93cd56706fcbfd.tar.gz
* 29.0.50.156996-3
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dde5cc6827c3..71d6122e43d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Development master branch.
pkgver = 29.0.50.156996
- pkgrel = 2
+ pkgrel = 3
url = http://www.gnu.org/software/emacs/
install = emacs-git.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index be1b8e45cd2a..65ecff084a52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,6 +35,8 @@ JIT="YES" # Enable native just-in-time compilation. libgccjit is in AUR.
# (setq comp-deferred-compilation t)
# to your .emacs file.
+AOT="YES" # Compile all elisp files.
+
CLI= # CLI only binary.
GPM= # Mouse support in Linux console using gpmd.
@@ -77,7 +79,7 @@ else
pkgname="emacs-git"
fi
pkgver=29.0.50.156996
-pkgrel=2
+pkgrel=3
pkgdesc="GNU Emacs. Development master branch."
arch=('x86_64')
url="http://www.gnu.org/software/emacs/"
@@ -86,7 +88,6 @@ depends_nox=('gnutls' 'libxml2' 'jansson')
depends=("${depends_nox[@]}" 'harfbuzz')
makedepends=('git')
provides=('emacs')
-conflicts=('emacs')
replaces=('emacs')
#source=("emacs-git::git://git.savannah.gnu.org/emacs.git")
source=("emacs-git::git+https://git.savannah.gnu.org/git/emacs.git")
@@ -315,7 +316,11 @@ _conf+=('--program-transform-name=s/\([ec]tags\)/\1.emacs/')
# are reusing your src directory!
#
- make
+ if [[ $JIT=="YES" ]] && [[ $AOT == "YES" ]]; then
+ make NATIVE_FULL_AOT=1
+ else
+ make
+ fi
# You may need to run this if 'loaddefs.el' files become corrupt.
#cd "$srcdir/emacs-git/lisp"