summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2022-11-22 22:31:54 +0000
committerPedro A. López-Valencia2022-11-22 22:31:54 +0000
commit51a4eac5e822f82e76d7d8f146268bb33698984f (patch)
treeafb2804b0fb799b2db22a9f6bbbad4b53587b8b5
parentf7c08fcc5e767e4a8e61d1da3145e241af99e083 (diff)
downloadaur-51a4eac5e822f82e76d7d8f146268bb33698984f.tar.gz
* Add and enable tree-sitter incremental language parsing support.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD16
2 files changed, 17 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d4939f22bd9..50b346961701 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Development master branch.
- pkgver = 29.0.50.160133
+ pkgver = 29.0.50.162441
pkgrel = 1
url = http://www.gnu.org/software/emacs/
install = emacs-git.install
@@ -26,6 +26,7 @@ pkgbase = emacs-git
depends = libtiff
depends = libxpm
depends = cairo
+ depends = tree-sitter
provides = emacs
replaces = emacs
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index d10fbb620ddb..9c63818987a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -69,6 +69,8 @@ ALSA= # Linux sound support.
NOCAIRO= # Disable here.
XWIDGETS= # Use GTK+ widgets pulled from webkit2gtk. Usable.
+
+SITTER="YES" # Use tree-sitter incremental language parsing.
DOCS_HTML= # Generate and install html documentation.
@@ -83,7 +85,7 @@ if [[ $CLI == "YES" ]] ; then
else
pkgname="emacs-git"
fi
-pkgver=29.0.50.160133
+pkgver=29.0.50.162441
pkgrel=1
pkgdesc="GNU Emacs. Development master branch."
arch=('x86_64')
@@ -186,6 +188,14 @@ if [[ $XWIDGETS == "YES" ]]; then
fi
fi
+if [[ $SITTER == "YES" ]]; then
+ if [[ $CLI == "YES" ]]; then
+ depends_nox+=( 'tree-sitter' );
+ else
+ depends+=( 'tree-sitter' );
+ fi
+fi
+
if [[ $GPM == "YES" ]]; then
if [[ $CLI == "YES" ]]; then
depends_nox+=( 'gpm' );
@@ -294,6 +304,10 @@ if [[ $XWIDGETS == "YES" ]]; then
_conf+=( '--with-xwidgets' );
fi
+if [[ $SITTER == "YES" ]]; then
+ _conf+=( '--with-tree-sitter' );
+fi
+
if [[ $GPM == "YES" ]]; then
true
else