summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2022-11-30 13:57:46 +0000
committerPedro A. López-Valencia2022-11-30 13:57:46 +0000
commit80fbd58b3d3893de586ae9485a187e2995c0c87b (patch)
tree9db39aed3120d2a62da08c77f184532dbdfe80a9
parent51a4eac5e822f82e76d7d8f146268bb33698984f (diff)
downloadaur-80fbd58b3d3893de586ae9485a187e2995c0c87b.tar.gz
* Adjust JIT and AOT compilation options to use new autoconf flags.
* Welcome to the new emacs 30 world.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD34
2 files changed, 21 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50b346961701..2e8e9e7dc94e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Development master branch.
- pkgver = 29.0.50.162441
+ pkgver = 30.0.50.162621
pkgrel = 1
url = http://www.gnu.org/software/emacs/
install = emacs-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 9c63818987a0..b07216db0197 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,8 +28,8 @@ GOLD= # Use the gold linker.
LTO= # Enable link-time optimization. Still experimental.
-JIT="YES" # Enable native just-in-time compilation. libgccjit is in AUR.
- # This compiles only performance critical elisp files.
+JIT="YES" # Enable native just-in-time compilation with libgccjit available
+ # in core. This compiles only performance critical elisp files.
#
# To compile all site-lisp on demand (repos/AUR packages,
# ELPA, MELPA, whatever), add
@@ -40,7 +40,7 @@ JIT="YES" # Enable native just-in-time compilation. libgccjit is in AUR.
# (setq native-compile-prune-cache t)
# to delete old versions.
-AOT= # Compile all elisp files.
+AOT= # Compile all elisp files provided by upstream.
CLI= # CLI only binary.
@@ -49,7 +49,9 @@ GPM= # Mouse support in Linux console using gpmd.
NOTKIT= # Use no toolkit widgets. Like B&W Twm (001d sk00l).
# Bitmap fonts only, 1337!
-PGTK= # Use native GTK3 build. Supports Wayland, yay!
+PGTK= # Use native GTK3 build. Supports Wayland, yay! Still
+ # has some problems if running under Xorg. Remember,
+ # this is my personal build file!
GTK3="YES" # GTK3 old windowing interface.
@@ -74,9 +76,11 @@ SITTER="YES" # Use tree-sitter incremental language parsing.
DOCS_HTML= # Generate and install html documentation.
-DOCS_PDF= # Generate and install pdf documentation.
+DOCS_PDF= # Generate and install pdf documentation. You need
+ # a TeX installation. I'm partial to upstream TeXLive.
-NOGZ="YES" # Don't compress .el files.
+NOGZ="YES" # Don't compress .el files. (Gain is neglible, IMHO)
+
################################################################################
################################################################################
@@ -85,7 +89,7 @@ if [[ $CLI == "YES" ]] ; then
else
pkgname="emacs-git"
fi
-pkgver=29.0.50.162441
+pkgver=30.0.50.162621
pkgrel=1
pkgdesc="GNU Emacs. Development master branch."
arch=('x86_64')
@@ -267,7 +271,15 @@ if [[ $LTO == "YES" ]]; then
fi
if [[ $JIT == "YES" ]]; then
- _conf+=( '--with-native-compilation' );
+ _conf+=( '--with-native-compilation=yes' );
+fi
+
+if [[ $JIT == "YES" ]] && [[ $AOT == "YES" ]]; then
+ _conf+=( '--with-native-compilation=aot' );
+fi
+
+if [[ ! $JIT == "YES" ]] && [[ ! $AOT == "YES" ]]; then
+ _conf+=( '--with-native-compilation=no' );
fi
if [[ $XI2 == "YES" ]]; then
@@ -336,12 +348,6 @@ _conf+=('--program-transform-name=s/\([ec]tags\)/\1.emacs/')
# are reusing your src directory!
#
- if [[ $JIT=="YES" ]] && [[ $AOT == "YES" ]]; then
- make NATIVE_FULL_AOT=1
- else
- make
- fi
-
# You may need to run this if 'loaddefs.el' files become corrupt.
#cd "$srcdir/emacs-git/lisp"
#make autoloads