summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2022-12-04 16:21:31 +0000
committerxiliuya2023-01-26 14:47:10 +0800
commitb7eb6a05d5fa62175c1ab5e526023a30440f6b37 (patch)
tree45629022c68226246eec126e402c15d3a5ad8c89
parent233c045525c1bdb16d24ca928ebe3d2faff19560 (diff)
downloadaur-b7eb6a05d5fa62175c1ab5e526023a30440f6b37.tar.gz
* Correct a big oops.
* Allow disabling sqlite3 support. * Allow option to compile with trampolines. You need to enable jit at least.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD24
2 files changed, 26 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb9e1aaa8bb8..df47d0765b42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -26,7 +26,9 @@ pkgbase = emacs29-git
depends = libwebp
depends = libtiff
depends = libxpm
+ depends = cairo
depends = tree-sitter
+ depends = sqlite3
provides = emacs
conflicts = emacs
replaces = emacs
diff --git a/PKGBUILD b/PKGBUILD
index a0b1cb1c17a3..eb263b216690 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -43,6 +43,8 @@ JIT="YES" # Enable native just-in-time compilation with libgccjit availa
AOT= # Compile all elisp files provided by upstream.
+TRAMPOLINES= # Compile jitted elisp files with trampolines.
+
CLI= # CLI only binary.
GPM= # Mouse support in Linux console using gpmd.
@@ -75,6 +77,8 @@ XWIDGETS= # Use GTK+ widgets pulled from webkit2gtk. Usable.
SITTER="YES" # Use tree-sitter incremental language parsing.
+NOSQLITE3= # Disable sqlite3 support.
+
DOCS_HTML= # Generate and install html documentation.
DOCS_PDF= # Generate and install pdf documentation. You need
@@ -202,6 +206,16 @@ if [[ $SITTER == "YES" ]]; then
fi
fi
+if [[ $NOSQLITE3 == "YES" ]]; then
+ true
+else
+ if [[ $CLI == "YES" ]]; then
+ depends_nox+=( 'sqlite3' );
+ else
+ depends+=( 'sqlite3' );
+ fi
+fi
+
if [[ $GPM == "YES" ]]; then
if [[ $CLI == "YES" ]]; then
depends_nox+=( 'gpm' );
@@ -322,6 +336,10 @@ if [[ $SITTER == "YES" ]]; then
_conf+=( '--with-tree-sitter' );
fi
+if [[ $NOSQLITE3 == "YES" ]]; then
+ _conf+=( '---without-sqlite3' );
+fi
+
if [[ $GPM == "YES" ]]; then
true
else
@@ -355,6 +373,12 @@ _conf+=('--program-transform-name=s/\([ec]tags\)/\1.emacs/')
#make autoloads
#cd ../build
+ if [[ $TRAMPOLINES == "YES" ]] && [[ $JIT == "YES" ]] ; then
+ make trampolines;
+ else
+ make
+ fi
+
# Optional documentation formats.
if [[ $DOCS_HTML == "YES" ]]; then
make html;