summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2022-09-23 10:31:06 -0500
committerPedro A. López-Valencia2022-09-23 10:31:06 -0500
commitb9b75eaca598dab6ea342a3a4b890b35a3351633 (patch)
tree5234273f9c6c81bde16b80e2758e2bcf53d92a6e
parentb9eb3b405717f8df37b38217dbb7d361b8ffca08 (diff)
downloadaur-b9b75eaca598dab6ea342a3a4b890b35a3351633.tar.gz
* Add a separate text file giving a hint on how to enable
automatic JIT compilation of site list. This hint applies both to lisp packages installed in the system's site-lisp directory as to those installed in the local $HOME/.emacs.d directory. In both cases, all cached JIT binaries are installed in $HOME/.emacs.d
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD3
-rw-r--r--site-list-aot.md8
4 files changed, 12 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3345ae9269e6..cb956d14fd8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Development master branch.
- pkgver = 29.0.50.157934
+ pkgver = 29.0.50.160038
pkgrel = 1
url = http://www.gnu.org/software/emacs/
install = emacs-git.install
diff --git a/.gitignore b/.gitignore
index d517c3782020..a7490fd0d82a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,3 +6,5 @@ src/
emacs-git
*.local
local
+LOCAL
+*.txt
diff --git a/PKGBUILD b/PKGBUILD
index a084fc0676ee..abf6d7effb75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -79,7 +79,7 @@ if [[ $CLI == "YES" ]] ; then
else
pkgname="emacs-git"
fi
-pkgver=29.0.50.157934
+pkgver=29.0.50.160038
pkgrel=1
pkgdesc="GNU Emacs. Development master branch."
arch=('x86_64')
@@ -90,7 +90,6 @@ depends=("${depends_nox[@]}" 'harfbuzz')
makedepends=('git')
provides=('emacs')
replaces=('emacs')
-#source=("emacs-git::git://git.savannah.gnu.org/emacs.git"
source=("emacs-git::git+https://git.savannah.gnu.org/git/emacs.git"
"nemacs")
options=(!strip)
diff --git a/site-list-aot.md b/site-list-aot.md
new file mode 100644
index 000000000000..866ac0bfe2c6
--- /dev/null
+++ b/site-list-aot.md
@@ -0,0 +1,8 @@
+# ON-DEMAND COMPILATION OF SITE-LISP AND LOCAL PACKAGES
+
+To compile all site-lisp on demand (repos/AUR packages, ELPA, MELPA,
+ whatever), add
+
+ (setq comp-deferred-compilation t)
+
+to your `.emacs` file.