summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2022-07-05 14:01:45 +0000
committerPedro A. López-Valencia2022-07-05 14:01:45 +0000
commitb9eb3b405717f8df37b38217dbb7d361b8ffca08 (patch)
treede40d406a303d8f3a62661ef0b1532075867bda5
parent9d7274ab097e142d8fddc5276f13c0c43cf7d793 (diff)
downloadaur-b9eb3b405717f8df37b38217dbb7d361b8ffca08.tar.gz
* Fix pkgver generation routine. Now it requires awk, because KISS.
* There's changes in the autoconf infrastructure and it seems full AOT compilation doesn't work anymore. Be advised.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 076ec3865d04..3345ae9269e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Development master branch.
- pkgver = 29.0.50.157115
+ pkgver = 29.0.50.157934
pkgrel = 1
url = http://www.gnu.org/software/emacs/
install = emacs-git.install
diff --git a/PKGBUILD b/PKGBUILD
index db061ba8a29f..a084fc0676ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,7 +31,8 @@ LTO= # Enable link-time optimization. Still experimental.
JIT="YES" # Enable native just-in-time compilation. libgccjit is in AUR.
# This compiles only performance critical elisp files.
#
- # To compile all elisp on demand, add
+ # To compile all site-lisp on demand (repos/AUR packages,
+ # ELPA, MELPA, whatever), add
# (setq comp-deferred-compilation t)
# to your .emacs file.
@@ -78,7 +79,7 @@ if [[ $CLI == "YES" ]] ; then
else
pkgname="emacs-git"
fi
-pkgver=29.0.50.157115
+pkgver=29.0.50.157934
pkgrel=1
pkgdesc="GNU Emacs. Development master branch."
arch=('x86_64')
@@ -200,9 +201,9 @@ pkgver() {
cd "$srcdir/emacs-git"
printf "%s.%s" \
- "$(grep AC_INIT configure.ac | \
- sed -e 's/^.\+\ \([0-9]\+\.[0-9]\+\.[0-9]\+\?\).\+$/\1/')" \
- "$(git rev-list --count HEAD)"
+ $(grep AC_INIT configure.ac | \
+ awk -F',' '{ gsub("[ \\[\\]]","",$2); print $2 }') \
+ $(git rev-list --count HEAD)
}
# There is no need to run autogen.sh after first checkout.