summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2021-06-05 13:50:39 -0500
committerPedro A. López-Valencia2021-06-05 13:50:39 -0500
commitdca21d899ec2b1390526a300c7a617a22165dbda (patch)
tree6cdad60a4f66846baf404cda72445697e1660156
parente065d2a6c2cc1da1ff0faca0af78a4d89789e21f (diff)
downloadaur-dca21d899ec2b1390526a300c7a617a22165dbda.tar.gz
* Change behavior of changing directory ownership during packaging
to a post_install routine. Thus, builds can be chrooted.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--emacs-git.install8
3 files changed, 19 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 069426fd6479..007334f2ef2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Development master branch.
- pkgver = 28.0.50.148045
+ pkgver = 28.0.50.148607
pkgrel = 1
url = http://www.gnu.org/software/emacs/
+ install = emacs-git.install
arch = x86_64
license = GPL3
makedepends = git
@@ -35,8 +36,7 @@ pkgbase = emacs-git
replaces = emacs-seq
replaces = emacs-nox
options = !strip
- source = emacs-git::git://git.savannah.gnu.org/emacs.git
+ source = emacs-git::git://github.com/emacs-mirror/emacs.git
b2sums = SKIP
pkgname = emacs-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 06d1ba44f0c5..b8bce09a661e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -59,7 +59,7 @@ if [[ $CLI == "YES" ]] ; then
else
pkgname="emacs-git"
fi
-pkgver=28.0.50.148045
+pkgver=28.0.50.148607
pkgrel=1
pkgdesc="GNU Emacs. Development master branch."
arch=('x86_64')
@@ -71,10 +71,11 @@ makedepends=('git')
provides=('emacs' 'emacs26-git' 'emacs-27-git' 'emacs-seq' 'emacs-nox')
conflicts=('emacs' 'emacs26-git' 'emacs-27-git' 'emacs-seq' 'emacs-nox')
replaces=('emacs' 'emacs26-git' 'emacs-27-git' 'emacs-seq' 'emacs-nox')
-source=("emacs-git::git://git.savannah.gnu.org/emacs.git")
+#source=("emacs-git::git://git.savannah.gnu.org/emacs.git")
# If Savannah fails for reasons, use Github's mirror
-#source=("emacs-git::git://github.com/emacs-mirror/emacs.git")
+source=("emacs-git::git://github.com/emacs-mirror/emacs.git")
options=(!strip)
+install="$pkgname".install
b2sums=('SKIP')
################################################################################
@@ -305,13 +306,15 @@ package() {
if [[ $DOCS_PDF == "YES" ]]; then make DESTDIR="$pkgdir/" install-pdf; fi
# fix user/root permissions on usr/share files
- find "$pkgdir"/usr/share/emacs/ | xargs chown root:root
+ # MOVED to install script
+ # find "$pkgdir"/usr/share/emacs/ | xargs chown root:root
# fix permssions on /var/games
mkdir -p "$pkgdir"/var/games/emacs
chmod 775 "$pkgdir"/var/games
chmod 775 "$pkgdir"/var/games/emacs
- chown -R root:games "$pkgdir"/var/games
+ # MOVED to install script
+ # chown -R root:games "$pkgdir"/var/games
}
diff --git a/emacs-git.install b/emacs-git.install
new file mode 100644
index 000000000000..61ca576ee87f
--- /dev/null
+++ b/emacs-git.install
@@ -0,0 +1,8 @@
+post_install() {
+ # fix user/root permissions on usr/share files
+ find "$pkgdir"/usr/share/emacs/ | xargs chown root:root
+ # make sure directory has the correct owner and group
+ chown -R root:games "$pkgdir"/var/games
+}
+
+# vim:sw=4:ts=4:et:ft=bash