summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2021-11-22 13:57:04 -0500
committerPedro A. López-Valencia2021-11-22 13:57:04 -0500
commite9198eeda18785494a33fa7b8d0406340354e3f7 (patch)
tree3b038fd63085859adf02e55a5f3542a753cc6d2e
parent19b0bb93c65e8b60cffcee3de84070c1e2897263 (diff)
downloadaur-e9198eeda18785494a33fa7b8d0406340354e3f7.tar.gz
* Drop GTK+2 configuaration.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 4 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c64f97497972..b9b93a834eb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Development master branch.
pkgver = 29.0.50.152009
- pkgrel = 1
+ pkgrel = 2
url = http://www.gnu.org/software/emacs/
install = emacs-git.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index f837f9392dfa..4ec7a25f349a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -52,8 +52,6 @@ LUCID= # Use the lucid, a.k.a athena, toolkit. Like XEmacs, sorta.
# Xft, if you choose no toolkit or Lucid.
#
-GTK2= # GTK2 support. Why would you?
-
NOCAIRO= # Disable here.
XWIDGETS= # Use GTK+ widgets pulled from webkit2gtk. Usable.
@@ -76,7 +74,7 @@ else
pkgname="emacs-git"
fi
pkgver=29.0.50.152009
-pkgrel=1
+pkgrel=2
pkgdesc="GNU Emacs. Development master branch."
arch=('x86_64')
url="http://www.gnu.org/software/emacs/"
@@ -136,9 +134,6 @@ elif [[ $NOTKIT == "YES" ]]; then
elif [[ $LUCID == "YES" ]]; then
depends+=( 'dbus' 'hicolor-icon-theme' 'libxinerama' 'libxfixes' 'lcms2' 'librsvg' 'xaw3d' 'libxrandr' );
makedepends+=( 'xorgproto' );
-elif [[ $GTK2 == "YES" ]]; then
- depends+=( 'gtk2' 'lcms2' );
- makedepends+=( 'xorgproto' );
else
depends+=( 'gtk3' );
makedepends+=( 'xorgproto' );
@@ -157,10 +152,10 @@ if [[ ! $NOCAIRO == "YES" ]] && [[ ! $CLI == "YES" ]] ; then
fi
if [[ $XWIDGETS == "YES" ]]; then
- if [[ $GTK2 == "YES" ]] || [[ $LUCID == "YES" ]] || [[ $NOTKIT == "YES" ]] || [[ $CLI == "YES" ]]; then
+ if [[ $LUCID == "YES" ]] || [[ $NOTKIT == "YES" ]] || [[ $CLI == "YES" ]]; then
echo "";
echo "";
- echo "Xwidgets support *requires* gtk+3!!!";
+ echo "Xwidgets support **requires** GTK+3!!!";
echo "";
echo "";
exit 1;
@@ -240,8 +235,6 @@ elif [[ $NOTKIT == "YES" ]]; then
_conf+=( '--with-x-toolkit=no' '--without-toolkit-scroll-bars' '--with-xft' '--without-xaw3d' );
elif [[ $LUCID == "YES" ]]; then
_conf+=( '--with-x-toolkit=lucid' '--with-xft' '--with-xaw3d' );
-elif [[ $GTK2 == "YES" ]]; then
- _conf+=( '--with-x-toolkit=gtk2' '--without-gsettings' '--without-xaw3d' );
else
_conf+=( '--with-x-toolkit=gtk3' '--without-xaw3d' );
fi