summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorerik-pro2018-12-22 22:56:38 +0300
committererik-pro2018-12-22 23:13:03 +0300
commit3143921be6200841c49a129594e58bddf3af34d1 (patch)
treef24afb584ff8520f6ed72822a9de7a1c03255a67
parentd4ad4deaca74d1560a222a06da354a8591e4fe57 (diff)
downloadaur-3143921be6200841c49a129594e58bddf3af34d1.tar.gz
update emacspeak to 49.0 version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD22
2 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 225f774d6480..67f7018dae6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,22 @@
pkgbase = emacspeak
pkgdesc = Emacs extension that provides spoken output
- pkgver = 42.0
- pkgrel = 1
+ pkgver = 49.0
+ pkgrel = 0
url = http://emacspeak.sf.net/
install = emacspeak.install
- arch = i686
arch = x86_64
license = GPL
license = LGPL
license = APACHE
depends = emacs
depends = tcl>=8.6
- depends = tcl<8.7
depends = tclx
+ depends = lesstif
depends = espeak
optdepends = eflite: software speech via the FLite TTS engine
optdepends = python: Google client, and wrapper for Emacspeak speech servers.
- source = https://github.com/tvraman/emacspeak/releases/download/42.0/emacspeak-42.0.tar.bz2
- md5sums = cbf0fb61180120d6eb18af572dae4606
+ source = https://github.com/tvraman/emacspeak/releases/download/49.0/emacspeak-49.0.tar.bz2
+ md5sums = 24a73d020c434e539ac88ea2041898b6 emacspeak-49.0.tar.bz2
pkgname = emacspeak
diff --git a/PKGBUILD b/PKGBUILD
index 669f5236bd20..d37f6a9e7cad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,36 @@
-# Maintainer: Steve Holmes <steve.holmes88@gmail.com>
-# Contributers: Chris Brannon <cmbrannon79@gmail.com>
+# Maintainer: erik-pro <aarnaarn2@gmail.com>
+# Contributor: Steve Holmes <steve.holmes88@gmail.com>
+# Contributor: Chris Brannon <cmbrannon79@gmail.com>
pkgname=emacspeak
-pkgver=42.0
-pkgrel=1
+pkgver=49.0
+pkgrel=0
pkgdesc="Emacs extension that provides spoken output"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://emacspeak.sf.net/"
license=('GPL' 'LGPL' 'APACHE')
depends=(emacs
'tcl>=8.6'
- 'tcl<8.7'
'tclx'
+ 'lesstif'
'espeak')
optdepends=('eflite: software speech via the FLite TTS engine'
'python: Google client, and wrapper for Emacspeak speech servers.')
install='emacspeak.install'
source=("https://github.com/tvraman/emacspeak/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2")
-md5sums=('cbf0fb61180120d6eb18af572dae4606')
+md5sums=('24a73d020c434e539ac88ea2041898b6 emacspeak-49.0.tar.bz2
+')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
sed -i -e 's|/etc/info-dir|$(DESTDIR)/etc/info-dir|g' info/Makefile
- rm -f lisp/g-client/*.elc
- rm -f sounds/default-8k/*.elc
}
build() {
cd "$srcdir/$pkgname-$pkgver"
make config
make
-
# This one isn't compiled by default, but a lot of folks use it.
- cd servers/linux-espeak
- make TCL_VERSION=8.6
+ make espeak
}
package() {