summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorerik-pro2018-12-22 23:55:38 +0300
committererik-pro2018-12-22 23:58:30 +0300
commit50885160b8d72a9ea8ced7f803c495417720e731 (patch)
treeb80b83a13d5ac9ca61b2314906dd954e56b941eb
parent2fc91f2aef32bf6882652791696b103f42d8e954 (diff)
downloadaur-50885160b8d72a9ea8ced7f803c495417720e731.tar.gz
update
-rw-r--r--PKGBUILD17
1 files changed, 3 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 099a8635375f..4bc5d26b031c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,6 +19,7 @@ source=("https://github.com/tvraman/emacspeak/releases/download/${pkgver}/${pkgn
md5sums=('24a73d020c434e539ac88ea2041898b6')
prepare() {
+ export DTK_PROGRAM="espeak"
cd "$srcdir/$pkgname-$pkgver"
sed -i -e 's|/etc/info-dir|$(DESTDIR)/etc/info-dir|g' info/Makefile
}
@@ -27,24 +28,12 @@ build() {
cd "$srcdir/$pkgname-$pkgver"
make config
make
- # This one isn't compiled by default, but a lot of folks use it.
+ # Espeak isn't compiled by default, but lots of folks use it.
make espeak
}
package() {
cd "$srcdir/$pkgname-$pkgver"
- install -dm755 "$pkgdir/etc"
- make DESTDIR="$pkgdir" install
- cd servers/linux-espeak
- make DESTDIR="$pkgdir" install
- # Interestingly, the source files are installed under DESTDIR.
- cd "$pkgdir/usr/share/emacs/site-lisp/emacspeak/servers/linux-espeak"
- rm -f tclespeak.cpp Makefile
- # A handful of files have permissions of 750 and 640; fix.
- cd "$pkgdir"
- find . -perm 640 -print0
- find . -perm 750 -print0
- rm -f "$pkgdir/usr/share/info/dir"
- rm -f "$pkgdir/etc/info-dir"
+ make prefix="${pkgdir}/usr" install
}