summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorerik-pro2018-12-30 14:34:40 +0300
committererik-pro2018-12-30 16:38:17 +0300
commit8f6347a884f7fd9b00c2211ad3ea4c6a679708d1 (patch)
treedf1e1e03e187746d305126419f31c935887bf93a
parent50885160b8d72a9ea8ced7f803c495417720e731 (diff)
downloadaur-8f6347a884f7fd9b00c2211ad3ea4c6a679708d1.tar.gz
fix pkg build
add fast and dirty fix. thanks "amerlyq"
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
-rw-r--r--emacspeak.install18
3 files changed, 16 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ca569165080..e806600f94c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = emacspeak
pkgdesc = Emacs extension that provides spoken output
pkgver = 49.0
- pkgrel = 0
+ pkgrel = 1
url = http://emacspeak.sf.net/
- install = emacspeak.install
arch = x86_64
license = GPL
license = LGPL
@@ -11,9 +10,9 @@ pkgbase = emacspeak
depends = emacs
depends = tcl>=8.6
depends = tclx
- depends = lesstif
depends = espeak
optdepends = python: Google client, and wrapper for Emacspeak speech servers.
+ optdepends = openmotif
source = https://github.com/tvraman/emacspeak/releases/download/49.0/emacspeak-49.0.tar.bz2
md5sums = 24a73d020c434e539ac88ea2041898b6
diff --git a/PKGBUILD b/PKGBUILD
index 4bc5d26b031c..8aad5092e737 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Chris Brannon <cmbrannon79@gmail.com>
pkgname=emacspeak
pkgver=49.0
-pkgrel=0
+pkgrel=1
pkgdesc="Emacs extension that provides spoken output"
arch=('x86_64')
url="http://emacspeak.sf.net/"
@@ -11,10 +11,9 @@ license=('GPL' 'LGPL' 'APACHE')
depends=(emacs
'tcl>=8.6'
'tclx'
- 'lesstif'
'espeak')
-optdepends=('python: Google client, and wrapper for Emacspeak speech servers.')
-install='emacspeak.install'
+optdepends=('python: Google client, and wrapper for Emacspeak speech servers.'
+ 'openmotif')
source=("https://github.com/tvraman/emacspeak/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2")
md5sums=('24a73d020c434e539ac88ea2041898b6')
@@ -33,7 +32,15 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make prefix="${pkgdir}/usr" install
-}
+ local d=$pkgdir/usr/share/emacs/site-lisp/emacspeak
+ install -d -- "$d"
+ cp -a "$srcdir/$pkgname-$pkgver/." "$d"
+ find "$d" \( -type d -or \( -type f -executable \) \) -execdir chmod 755 {} +
+ find "$d" -type f -not -executable -execdir chmod 644 {} +
+ # Add convenient wrapper to keep your configs unmodified
+ local s=$pkgdir/usr/bin/emacspeak
+ install -d -- "${s%/*}"
+ printf '#!/bin/sh\nemacs -l '"'%s'"' "$@"\n' "${d#$pkgdir}/lisp/emacspeak-setup.elc" >"$s"
+ chmod 755 "$s"
+}
diff --git a/emacspeak.install b/emacspeak.install
deleted file mode 100644
index d92630751884..000000000000
--- a/emacspeak.install
+++ /dev/null
@@ -1,18 +0,0 @@
-INFO_DIR=/usr/share/info
-info_files=(emacspeak)
-
-post_install() {
- for f in ${info_files[@]}; do
- install-info ${INFO_DIR}/$f.info.gz ${INFO_DIR}/dir 2> /dev/null
- done
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- for f in ${info_files[@]}; do
- install-info --delete ${INFO_DIR}/$f.info.gz ${INFO_DIR}/dir 2> /dev/null
- done
-}