summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:24:42 +0200
committerStefan Husmann2015-06-09 00:24:42 +0200
commit6d147296be5a7a75d0bd69c4598d1f642f2850bb (patch)
treeddfef5c560722d9298e66b0a8d45d55b5bbdf09c
downloadaur-6d147296be5a7a75d0bd69c4598d1f642f2850bb.tar.gz
initial version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cfc1027aaa9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = emact
+ pkgdesc = A portable emacs clone for X Windows or terminal with a lisp interpreter.
+ pkgver = 2.54.0
+ pkgrel = 2
+ url = http://christian.jullien.free.fr/emacs/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libx11
+ source = http://www.eligis.com/emacs/emact-2.54.0.tar.gz
+ md5sums = b43e9e745a129ab3578e9e2b06eb8b6d
+
+pkgname = emact
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ee3a376b6e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Colin Drake <colin.f.drake@gmail.com>
+pkgname=emact
+pkgver=2.54.0
+pkgrel=2
+pkgdesc="A portable emacs clone for X Windows or terminal with a lisp interpreter."
+arch=('i686' 'x86_64')
+url="http://christian.jullien.free.fr/emacs/"
+license=('GPL')
+depends=('libx11')
+source=("http://www.eligis.com/emacs/$pkgname-$pkgver.tar.gz")
+md5sums=('b43e9e745a129ab3578e9e2b06eb8b6d')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make INSTALL="$pkgdir/usr/" install
+}