summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Gisbers2015-12-16 16:04:57 +0100
committerMichael Gisbers2015-12-16 16:04:57 +0100
commit67f97acc8a340e0804c7f5d5da8d5da19884947f (patch)
tree2aee235ee156e61f5f3aa87d0e829a72fa1da00c
downloadaur-email.tar.gz
commit email 3.1.3-2
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD30
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21f6bc23e1d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Wed Dec 16 15:04:57 UTC 2015
+pkgbase = email
+ pkgdesc = A simple command line client for SMTP
+ pkgver = 3.1.3
+ pkgrel = 2
+ url = http://www.cleancode.org/projects/email/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = openssl
+ backup = etc/email/email.address.template
+ backup = etc/email/email.conf
+ backup = etc/email/email.help
+ backup = etc/email/email.sig
+ backup = etc/email/mime.types
+ source = http://www.cleancode.org/downloads/email/email-3.1.4.tar.gz
+ md5sums = b9d5d201bef581d601d73a524373db60
+
+pkgname = email
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ed5120cebd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Michael Gisbers <michael@gisbers.de>
+# Contributor: Dennis Craven <dcraven @ gmail . com>
+
+pkgname=email
+pkgver=3.1.3
+pkgrel=2
+pkgdesc="A simple command line client for SMTP"
+arch=('i686' 'x86_64')
+url="http://www.cleancode.org/projects/email/"
+license=('GPL')
+depends=('openssl')
+backup=(etc/email/{email.{address.template,conf,help,sig},mime.types})
+# the email-3.1.4.tar.gz source archive contains an email-3.1.3 directory
+# configure.in also declares AC_INIT(email, 3.1.3, <deanjones@cleancode.org>)
+# we will assume the real version is 3.1.3 despite the source archive name
+# we will bump the pkgrel to 2 but leave the pkgver as 3.1.3 given the above
+# source=(http://www.cleancode.org/downloads/email/email-$pkgver.tar.gz)
+source=(http://www.cleancode.org/downloads/email/email-3.1.4.tar.gz)
+md5sums=('b9d5d201bef581d601d73a524373db60')
+
+build() {
+ cd "$srcdir/email-$pkgver"
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "$srcdir/email-$pkgver"
+ make DESTDIR="$pkgdir" install
+}