summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2023-11-14 22:41:18 +0100
committerMarcell Meszaros2023-11-14 22:42:24 +0100
commitfd654eb4ff0f280e4dc7d4a562ac775199579804 (patch)
treeb409544d8295754718d827ef38d44597b715845c
parentdbb97615e36462ee8c3b252c164983b7e3d14d43 (diff)
downloadaur-eman2.tar.gz
turn this into an empty package as it's dead anyway
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
-rwxr-xr-xeman2-installer133
-rw-r--r--eman2.sh6
4 files changed, 5 insertions, 184 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f409fc436c51..990fe56200bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,11 @@
pkgbase = eman2
- pkgdesc = Greyscale scientific image processing suite for processing data from transmission electron microscopes
+ pkgdesc = [Defunct] Greyscale scientific image processing suite for processing data from transmission electron microscopes
pkgver = 2.12
pkgrel = 6
url = http://blake.bcm.edu/emanwiki/EMAN2
arch = x86_64
license = GPL
- depends = python2-numpy
- depends = hdf5
- depends = fftw
- depends = boost
- depends = qt4
- depends = cmake
- depends = gsl
- depends = ftgl
- depends = python2-matplotlib
- depends = ipython
- depends = python2-pyqt4
- depends = python2-opengl
- options = !strip
source = http://ncmi.bcm.edu/ncmi/software/counter_222/software_133/manage_addProduct/NCMI/attendee_factory/eman2.12.linux64.tar.gz
- source = eman2.sh
md5sums = 2e21b310c957fc3b21f8c6b551b60fdb
- md5sums = SKIP
pkgname = eman2
-
diff --git a/PKGBUILD b/PKGBUILD
index ecc213bb466c..28b17217d1ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,10 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# Maintainer: Joshua Hardy <joshinsilico@gmail.com>
+# Contributor: Joshua Hardy <joshinsilico@gmail.com>
pkgname=eman2
pkgver=2.12
pkgrel=6
-pkgdesc="Greyscale scientific image processing suite for processing data from transmission electron microscopes"
+pkgdesc="[Defunct] Greyscale scientific image processing suite for processing data from transmission electron microscopes"
arch=(x86_64)
url="http://blake.bcm.edu/emanwiki/EMAN2"
license=('GPL')
-depends=('python2-numpy' 'hdf5' 'fftw' 'boost' 'qt4' 'cmake' 'gsl' 'ftgl' 'python2-matplotlib' 'ipython' 'python2-pyqt4' 'python2-opengl')
-source=("http://ncmi.bcm.edu/ncmi/software/counter_222/software_133/manage_addProduct/NCMI/attendee_factory/eman$pkgver.linux64.tar.gz" 'eman2.sh')
-md5sums=('2e21b310c957fc3b21f8c6b551b60fdb' 'SKIP')
-options=(!strip)
-
-prepare () {
- cd "$srcdir/EMAN2"
- sed -i -e s:"EMAN2PYTHON=\$1":"EMAN2PYTHON=/opt/eman2/Python/bin/python":g eman2-installer
-}
-build() {
- cd "$srcdir/EMAN2"
- ./eman2-installer
- echo "Restart computer to refresh eman paths and libraries."
-}
-
-package() {
- cd "$srcdir/EMAN2"
- install -d $pkgdir/opt/eman2 $pkgdir/etc/profile.d/
- cp -r * $pkgdir/opt/eman2/.
- install -D -m755 $srcdir/eman2.sh $pkgdir/etc/profile.d/.
-}
+source=("http://ncmi.bcm.edu/ncmi/software/counter_222/software_133/manage_addProduct/NCMI/attendee_factory/eman$pkgver.linux64.tar.gz")
+md5sums=('2e21b310c957fc3b21f8c6b551b60fdb')
diff --git a/eman2-installer b/eman2-installer
deleted file mode 100755
index 98c49d6b5029..000000000000
--- a/eman2-installer
+++ /dev/null
@@ -1,133 +0,0 @@
-#!/bin/bash
-
-# Purpose: Assist to install eman2 binary release.
-# Usage: eman2-installer
-# Date: 9/1/2004, by Liwei Peng
-# Date: 10/25/2007, modified by Grant Tang for EMAN2
-# Date: 1/28/2009, modified by Grant Tang for EMAN2 Pythn2.6
-# Date: 2/12/2009, change back to Python 2.5.4, Grant Tang
-# Date: 9/1/2009, --disable_cache, Grant Tang
-# Date: 6/30/2013, Significant updates by Ian Rees for new build system.
-# Date: 8/01/2013, changed disable_cache to disable_gui
-# Date: 1/23/2017, altered eman2.[bashrc/cshrc] files to include new matplotlibrc file in extlib
-usage()
-{
- echo "usage: `basename $0` [--disable_gui]"
- echo " --disable_gui: no GUI"
- exit 0
-}
-
-setup_shell() {
- # Setup bashrc or cshrc
- MYSHELL=`basename ${SHELL}`
- RCFILE=""
- if test ${MYSHELL} = "tcsh" || test ${MYSHELL} = "csh"; then
- RCFILE=".cshrc"
- setup_csh ${EMAN2DIR}/eman2${RCFILE}
- elif test ${MYSHELL} = "bash" || test ${MYSHELL} = "sh"; then
- RCFILE=".bashrc"
- setup_bash ${EMAN2DIR}/eman2$RCFILE
- elif test ${MYSHELL} = "zsh"; then
- RCFILE=".zshrc"
- setup_bash ${EMAN2DIR}/eman2$RCFILE
- else
- echo "Unkown shell. You will need set up your enviroment variables manually."
- fi
- if test "X${RCFILE}" != "X"; then
- echo ""
- echo "If you experience any problems after installation, please see for tips:"
- echo "http:/eman2.org/Install/BinaryInstall"
- fi
-}
-
-setup_csh() {
- OUT=$1
- echo "setenv EMAN2DIR ${EMAN2DIR}" > ${OUT}
- echo 'setenv PATH ${EMAN2DIR}/bin:${EMAN2DIR}/extlib/bin:${PATH}' >> ${OUT}
- echo 'if ($?PYTHONPATH == 0) then' >> ${OUT}
- echo ' setenv PYTHONPATH ${EMAN2DIR}/lib:${EMAN2DIR}/bin' >> ${OUT}
- echo 'else' >> ${OUT}
- echo ' setenv PYTHONPATH ${EMAN2DIR}/lib:${EMAN2DIR}/bin:${PYTHONPATH}' >> ${OUT}
- echo 'endif' >> ${OUT}
- echo 'setenv MATPLOTLIBRC ${EMAN2DIR}/extlib' >> ${OUT}
- echo 'alias sparx sx.py' >> ${OUT}
- echo "setenv LC_CTYPE=en_US.utf8"
- echo "setenv LC_ALL=en_US.utf8"
-}
-
-setup_bash()
-{
- OUT=$1
- echo "export EMAN2DIR=${EMAN2DIR}" > ${OUT}
- echo 'export PATH=${EMAN2DIR}/bin:${EMAN2DIR}/extlib/bin:$PATH' >> ${OUT}
- echo 'export PYTHONPATH=${EMAN2DIR}/lib:${EMAN2DIR}/bin:${PYTHONPATH}' >> ${OUT}
- echo 'export MATPLOTLIBRC=${EMAN2DIR}/extlib' >> ${OUT}
- echo 'export LC_CTYPE=en_US.utf8'
- echo 'export LC_ALL=en_US.utf8'
- echo 'alias sphire=sxgui.py' >> ${OUT}
- echo 'alias sparx=sx.py' >> ${OUT}
-}
-
-setup_python()
-{
- EMAN2PYTHON=$1
- # Update python interpreter
- find ${EMAN2DIR}/extlib/bin -name "ipython" \
- -exec sed -i "s%^\#\!.*python.*$%\#\!$/opt/eman2/extlib/bin/python%" {} \;
- find ${EMAN2DIR}/test ${EMAN2DIR}/bin ${EMAN2DIR}/lib ${EMAN2DIR}/examples -name "*.py" \
- -exec sed -i "s%^\#\!.*python.*$%\#\!$/opt/eman2/extlib/bin/python%" {} \;
- find ${EMAN2DIR}/test ${EMAN2DIR}/bin ${EMAN2DIR}/lib ${EMAN2DIR}/examples -name "*.py" \
- -exec chmod a+x {} \;
- # ... and for SPARX
- # sed -i "s%^\#\!.*python.*$%\#\!${EMAN2PYTHON}%" ${EMAN2DIR}/bin/sparx
-}
-
-disable_cache()
-{
- cd ${EMAN2DIR}/lib
- echo "start substituting..."
- mv global_def.py global_def.py.bak
- sed -e 's/CACHE_DISABLE = False/CACHE_DISABLE = True/' global_def.py.bak > global_def.py
- rm -f global_def.py.bak
- cd ${EMAN2DIR}/bin
- mv sx_real.py sx_real.py.bak
- sed -e 's/GUIUSE = True/GUIUSE = False/' sx_real.py.bak > sx_real.py
- rm -f sx_real.py.bak
- cd ${EMAN2DIR}
-}
-
-main()
-{
- # Use the run directory as the EMAN2DIR.
- export EMAN2DIR=`pwd`
- export EMAN2PYTHON=${EMAN2DIR}/extlib/bin/python
-
- # Setup the Python interpreter
- if [ -f $EMAN2PYTHON ]
- then
- setup_python $EMAN2PYTHON
- fi
-
- # Setup bashrc or cshrc
- setup_shell
-
- # This is for Fedora Linux's SELinux limitation on shared libraries
- cd ${EMAN2DIR}/lib
- if [ -x /usr/bin/chcon ]; then
- chcon -t texrel_shlib_t *.so 2>/dev/null >/dev/null
- fi
- cd ${EMAN2DIR}
-
- # # This is for Pawel's cluster working
- local value1=$1
- if [[ "${value1}" = "--disable_gui" ]]; then
- disable_cache
- fi
-
- #for mpi_eman compilation
- # cd ${EMAN2DIR}/mpi_eman
- # sed -i 's,/usr/include/python2.6,${EMAN2DIR}/Python/include/python2.7,g' Makefile.*
-}
-
-main $1
-exit 0
diff --git a/eman2.sh b/eman2.sh
deleted file mode 100644
index a2b8e8eda9ff..000000000000
--- a/eman2.sh
+++ /dev/null
@@ -1,6 +0,0 @@
-#source /opt/eman2/eman2.bashrc
-export EMAN2DIR=/opt/eman2
-export PATH=$PATH:${EMAN2DIR}/bin:${EMAN2DIR}/extlib/bin
-export PYTHONPATH=${PYTHONPATH}:${EMAN2DIR}/lib:${EMAN2DIR}/bin
-alias sparx=sx.py
-