summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Hardy2016-04-10 21:56:39 +1000
committerJoshua Hardy2016-04-10 21:56:39 +1000
commit1c9619c728c19525ff5de110d751d04e947e1430 (patch)
treec584b3f59a276a4fda5f9d220f097d5b6eb3043e
downloadaur-1c9619c728c19525ff5de110d751d04e947e1430.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
-rw-r--r--eman2.sh1
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0ac8e29275c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = eman2
+ pkgdesc = Greyscale scientific image processing suite for processing data from transmission electron microscopes
+ pkgver = 2.12
+ pkgrel = 1
+ url = http://blake.bcm.edu/emanwiki/EMAN2
+ arch = x86_64
+ license = GPL
+ options = !strip
+ source = http://ncmi.bcm.edu/ncmi/software/counter_222/software_133/manage_addProduct/NCMI/attendee_factory/eman2.12.linux64.tar.gz
+ source = eman2.sh
+ md5sums = 2e21b310c957fc3b21f8c6b551b60fdb
+ md5sums = SKIP
+
+pkgname = eman2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d20fceda3f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Joshua Hardy <joshinsilico@gmail.com>
+pkgname=eman2
+pkgver=2.12
+pkgrel=1
+pkgdesc="Greyscale scientific image processing suite for processing data from transmission electron microscopes"
+arch=(x86_64)
+url="http://blake.bcm.edu/emanwiki/EMAN2"
+license=('GPL')
+depends=()
+source=("http://ncmi.bcm.edu/ncmi/software/counter_222/software_133/manage_addProduct/NCMI/attendee_factory/eman$pkgver.linux64.tar.gz"
+'eman2.sh')
+md5sums=('2e21b310c957fc3b21f8c6b551b60fdb' 'SKIP')
+options=(!strip)
+
+build() {
+ cd "$srcdir/EMAN2"
+ ./eman2-installer
+}
+
+package() {
+ cd "$srcdir/EMAN2"
+ install -d $pkgdir/opt/eman2 $pkgdir/etc/profile.d/
+ cp -r * $pkgdir/opt/eman2/.
+ install -D -m755 $srcdir/eman2.sh $pkgdir/etc/profile.d/.
+ source $pkdir/etc/profile.d/eman2.sh
+}
diff --git a/eman2.sh b/eman2.sh
new file mode 100644
index 000000000000..64f8f4763ca6
--- /dev/null
+++ b/eman2.sh
@@ -0,0 +1 @@
+source /opt/eman2/eman2.bashrc