summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052025-03-19 14:08:31 +0800
committerzxp198210052025-03-19 14:08:31 +0800
commit0ae575305ed0d20c357f9b34ed4dbf21c684be02 (patch)
tree301bed02a9a3d91238fc6a251d8fdcbf745720b4
downloadaur-0ae575305ed0d20c357f9b34ed4dbf21c684be02.tar.gz
update to 0.1.6
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD45
-rw-r--r--embertune.sh29
3 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c86e38612b3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = embertune-bin
+ pkgdesc = A desktop music player with a focus on design and functionality, aims to be a solid alternative to your streaming services without any ads.(Prebuilt version.Use system-wide electron)
+ pkgver = 0.1.6
+ pkgrel = 1
+ url = https://github.com/DylanAkp/EmberTune
+ arch = x86_64
+ license = MIT
+ makedepends = fuse2
+ depends = electron35
+ provides = embertune=0.1.6
+ conflicts = embertune
+ source = embertune-0.1.6.AppImage::https://github.com/DylanAkp/EmberTune/releases/download/v0.1.6/EmberTune-0.1.6.AppImage
+ source = LICENSE::https://raw.githubusercontent.com/DylanAkp/EmberTune/main/LICENSE
+ source = embertune.sh
+ sha256sums = 335daae2618db538446f1393c5c89388676f3a89875aabdd24e1e3613936bc1a
+ sha256sums = 41ed1adf2638cb0f5c93b0b0862013d4e4493079b64979e014453d84b6a0186a
+ sha256sums = 291f50480f5a61bc9c68db7d44cd0412071128706baa868a9cb854f8779a1980
+
+pkgname = embertune-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23e2617ecd34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=embertune-bin
+_pkgname=EmberTune
+pkgver=0.1.6
+_electronversion=35
+pkgrel=1
+pkgdesc="A desktop music player with a focus on design and functionality, aims to be a solid alternative to your streaming services without any ads.(Prebuilt version.Use system-wide electron)"
+arch=('x86_64')
+url="https://github.com/DylanAkp/EmberTune"
+license=('MIT')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=(
+ "electron${_electronversion}"
+)
+makedepends=(
+ 'fuse2'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${_pkgname}-${pkgver}.AppImage"
+ "LICENSE::https://raw.githubusercontent.com/DylanAkp/EmberTune/main/LICENSE"
+ "${pkgname%-bin}.sh"
+)
+sha256sums=('335daae2618db538446f1393c5c89388676f3a89875aabdd24e1e3613936bc1a'
+ '41ed1adf2638cb0f5c93b0b0862013d4e4493079b64979e014453d84b6a0186a'
+ '291f50480f5a61bc9c68db7d44cd0412071128706baa868a9cb854f8779a1980')
+prepare() {
+ sed -i -e "
+ s/@electronversion@/${_electronversion}/g
+ s/@appname@/${pkgname%-bin}/g
+ s/@runname@/app.asar/g
+ s/@cfgdirname@/${_pkgname}/g
+ s/@options@/env ELECTRON_OZONE_PLATFORM_HINT=auto/g
+ " "${srcdir}/${pkgname%-bin}.sh"
+ chmod +x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+ sed -i "s/AppRun --no-sandbox/${pkgname%-bin}/g" "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file
diff --git a/embertune.sh b/embertune.sh
new file mode 100644
index 000000000000..40e422ca2ee7
--- /dev/null
+++ b/embertune.sh
@@ -0,0 +1,29 @@
+#!/bin/bash
+set -o pipefail
+_APPDIR="/usr/lib/@appname@"
+_RUNNAME="${_APPDIR}/@runname@"
+_CFGDIR="@cfgdirname@/"
+_OPTIONS="@options@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
+export ELECTRON_DISABLE_SECURITY_WARNINGS=true
+export ELECTRON_OVERRIDE_DIST_PATH="/usr/bin/electron@electronversion@"
+export NODE_ENV=production
+export XDG_CONFIG_HOME="${XDG_CONFIG_HOME:-$HOME/.config}"
+export _FLAGS_FILE="${XDG_CONFIG_HOME}/${_CFGDIR}@appname@-flags.conf"
+declare -a _USER_FLAGS
+if [[ -f "${_FLAGS_FILE}" ]]; then
+ while read -r line; do
+ if [[ ! "${line}" =~ ^[[:space:]]*#.* ]]; then
+ _USER_FLAGS+=("${line}")
+ fi
+ done < "${_FLAGS_FILE}"
+fi
+cd "${_APPDIR}" || { echo "Failed to change directory to ${_APPDIR}"; exit 1; }
+if [[ "${EUID}" -ne 0 ]] || [[ "${ELECTRON_RUN_AS_NODE}" ]]; then
+ exec electron@electronversion@ "${_RUNNAME}" ${_OPTIONS} "${_USER_FLAGS[@]}" "$@"
+else
+ exec electron@electronversion@ "${_RUNNAME}" ${_OPTIONS} --no-sandbox "${_USER_FLAGS[@]}" "$@"
+fi \ No newline at end of file