summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmish2022-02-14 14:55:11 +0530
committerAmish2022-02-14 14:55:11 +0530
commit15b08891b4a88307d2e0a65a97417e283216a09f (patch)
tree82df7942b3f1c63b1c7a4a23cda6b8eba3d2505d
downloadaur-15b08891b4a88307d2e0a65a97417e283216a09f.tar.gz
Initial release 3.1.0.0
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2f19532826e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = embridge-bin
+ pkgdesc = Secure channel between network applications and keys stored in hardware tokens
+ pkgver = 3.1.0.0
+ pkgrel = 1
+ url = https://embridge.emudhra.com
+ arch = x86_64
+ license = custom
+ depends = curl
+ depends = libunwind
+ depends = openssl-1.0
+ options = libtool
+ options = staticlibs
+ options = !strip
+ source = https://resources.emudhra.com/hs/Ubuntu/latest/emBridge.zip
+ sha512sums = 557fb42e3f0a1a01d91f32bbeeb1a3fc128bc44cbcea586b7b9860461d6fc75778943369b2c882b8199e01c1f951fd1381fbb6c165c851be646109b18a5ecd31
+
+pkgname = embridge-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8f5b05114000
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*x86_64.pkg.tar.zsr
+emBridge.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d12d3629e3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Amish <contact at via dot aur>
+pkgname=embridge-bin
+pkgver=3.1.0.0
+pkgrel=1
+pkgdesc='Secure channel between network applications and keys stored in hardware tokens'
+arch=(x86_64)
+url='https://embridge.emudhra.com'
+license=('custom')
+depends=('curl' 'libunwind' 'openssl-1.0')
+source=(https://resources.emudhra.com/hs/Ubuntu/latest/emBridge.zip)
+sha512sums=('557fb42e3f0a1a01d91f32bbeeb1a3fc128bc44cbcea586b7b9860461d6fc75778943369b2c882b8199e01c1f951fd1381fbb6c165c851be646109b18a5ecd31')
+options=('libtool' 'staticlibs' '!strip')
+
+package() {
+ cd "${srcdir}"
+ msg2 "Extracting the emBridge-v${pkgver}.deb"
+ ar po "emBridge-v${pkgver}.deb" data.tar.xz | bsdtar -C "${pkgdir}" -xf - --no-same-owner
+ cd "${pkgdir}/opt/eMudhra/emBridge"
+ find . -type f -exec chmod 644 {} \+
+ find . -name '*.dll' -exec chmod 755 {} \+
+ find . -name '*.sh' -exec chmod 755 {} \+
+ find . -name '*.so' -exec chmod 755 {} \+
+ chmod 755 createdump emBridge
+ install -Dm755 /dev/stdin "${pkgdir}/usr/bin/embridge" << 'EOF'
+#!/bin/bash
+mkdir -p ~/Documents/embridge
+cd ~/Documents/embridge
+export ASPNETCORE_ENVIRONMENT="Production"
+export ASPNETCORE_HTTPS_PORT=26769
+export ASPNETCORE_URLS="https://localhost.emudhra.com:26769"
+/opt/eMudhra/emBridge/emBridge
+EOF
+}