summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmish2022-06-11 16:33:05 +0530
committerAmish2022-06-11 16:33:05 +0530
commit9762a5e1ce597b71fd65c3750ac56444c73bb800 (patch)
tree4c0ee00c81b42daa6115a27d7612d678f86d1afc
parent8bf3640b4c513d92c5e1cdf2e6323b105d969167 (diff)
downloadaur-9762a5e1ce597b71fd65c3750ac56444c73bb800.tar.gz
Patch to set System.Globalization.Invariant to true
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--runtimeconfig.patch14
3 files changed, 23 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03b938edc02e..e363cfb95e09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = embridge-bin
pkgdesc = Secure channel between network applications and keys stored in hardware tokens
pkgver = 3.1.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://embridge.emudhra.com
arch = x86_64
license = custom
@@ -12,6 +12,8 @@ pkgbase = embridge-bin
options = staticlibs
options = !strip
source = emBridge-3.1.7.0.zip::https://resources.emudhra.com/hs/Ubuntu/latest/emBridge.zip
+ source = runtimeconfig.patch
sha512sums = cb29bafd903768194f2bf03d3c56286b97891403792dfca4b790b8841640e869b46d94514f710f7f1138871f08d2815c5946156ede38d0a107b7197dc5f5e5fc
+ sha512sums = 566fdfceb9c53614b30f4ba7851f5a9de502e9cfa1e45ed7b1a804d1c6112f25944a302ba07e89f05815acb580952aed3932a81c66dd0141c1913e7d56390309
pkgname = embridge-bin
diff --git a/PKGBUILD b/PKGBUILD
index 95c8fd05f426..6dda06013215 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
# Maintainer: Amish <contact at via dot aur>
pkgname=embridge-bin
pkgver=3.1.7.0
-pkgrel=1
+pkgrel=2
pkgdesc='Secure channel between network applications and keys stored in hardware tokens'
arch=(x86_64)
url='https://embridge.emudhra.com'
license=('custom')
depends=('curl' 'libunwind' 'openssl')
-source=("emBridge-${pkgver}.zip::https://resources.emudhra.com/hs/Ubuntu/latest/emBridge.zip")
-sha512sums=('cb29bafd903768194f2bf03d3c56286b97891403792dfca4b790b8841640e869b46d94514f710f7f1138871f08d2815c5946156ede38d0a107b7197dc5f5e5fc')
+source=("emBridge-${pkgver}.zip::https://resources.emudhra.com/hs/Ubuntu/latest/emBridge.zip"
+ "runtimeconfig.patch")
+sha512sums=('cb29bafd903768194f2bf03d3c56286b97891403792dfca4b790b8841640e869b46d94514f710f7f1138871f08d2815c5946156ede38d0a107b7197dc5f5e5fc'
+ '566fdfceb9c53614b30f4ba7851f5a9de502e9cfa1e45ed7b1a804d1c6112f25944a302ba07e89f05815acb580952aed3932a81c66dd0141c1913e7d56390309')
options=('libtool' 'staticlibs' '!strip')
package() {
@@ -30,4 +32,5 @@ export ASPNETCORE_HTTPS_PORT=26769
export ASPNETCORE_URLS="https://localhost.emudhra.com:26769"
/opt/eMudhra/emBridge/emBridge
EOF
+ patch -p0 -d "${pkgdir}" -i "${srcdir}"/runtimeconfig.patch
}
diff --git a/runtimeconfig.patch b/runtimeconfig.patch
new file mode 100644
index 000000000000..08b4df28da91
--- /dev/null
+++ b/runtimeconfig.patch
@@ -0,0 +1,14 @@
+--- opt/eMudhra/emBridge/emBridge.runtimeconfig.json 2022-06-11 08:08:17.000000000 +0530
++++ opt/eMudhra/emBridge/emBridge.runtimeconfig.json 2022-06-11 08:06:20.057235785 +0530
+@@ -12,7 +12,8 @@
+ }
+ ],
+ "configProperties": {
+- "System.GC.Server": true
++ "System.GC.Server": true,
++ "System.Globalization.Invariant": true
+ }
+ }
+-}
+\ No newline at end of file
++}