summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2017-04-04 12:10:48 -0700
committerShadowKyogre2017-04-04 12:10:48 -0700
commit15fb5924c5ed2ea3fa14f7be3f1168e33fa8aef2 (patch)
tree9b601cab430064e22a6cd9af9d528b01ca513601
parent2c6bde65b4c2f12a2797c455fbab4e9bdc78ce82 (diff)
downloadaur-15fb5924c5ed2ea3fa14f7be3f1168e33fa8aef2.tar.gz
Tidy dependencies after namcap scan
libwnck already depends on gtk2, so we can remove gtk2 as an explicit dependency
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD12
3 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64f8d9ee0c79..f792846f83da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Mon Apr 11 23:25:58 UTC 2016
+# Tue Apr 4 19:01:53 UTC 2017
pkgbase = emerald-git
pkgdesc = Emerald window decorator
- pkgver = 0.8.12.4.r2.gee2031a
+ pkgver = 0.8.12.4.r38.gd3eba71
pkgrel = 1
url = https://github.com/compiz-reloaded/emerald
- install = emerald.install
arch = i686
arch = x86_64
groups = compiz-fusion
@@ -16,11 +15,10 @@ pkgbase = emerald-git
makedepends = pkg-config
makedepends = gettext
depends = compiz-core-git
- depends = libwnck
- depends = gtk2
depends = libxres
depends = shared-mime-info
depends = xdg-utils
+ depends = libwnck
depends = desktop-file-utils
depends = hicolor-icon-theme
provides = emerald
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a5401c5d685d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index a5cbbd22d5d4..bec8f30bfe95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,25 +7,29 @@
_upstream="emerald"
pkgname=emerald-git
-pkgver=0.8.12.4.r2.gee2031a
+pkgver=0.8.12.4.r38.gd3eba71
pkgrel=1
pkgdesc="Emerald window decorator"
arch=('i686' 'x86_64')
url="https://github.com/compiz-reloaded/${_upstream}"
license=('GPL')
-depends=('compiz-core-git' 'libwnck' 'gtk2' 'libxres' 'shared-mime-info' 'xdg-utils' \
+depends=('compiz-core-git' 'libxres' 'shared-mime-info' 'xdg-utils' 'libwnck'
'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('intltool' 'pkg-config' 'gettext')
groups=('compiz-fusion' 'compiz-fusion-kde' 'compiz-fusion-gtk')
options=(!libtool)
conflicts=('emerald0.9' 'emerald')
provides=('emerald')
-install=emerald.install
source=(
"git+https://github.com/compiz-reloaded/${_upstream}.git"
)
sha1sums=('SKIP')
+_configure_opts=(
+ '--prefix=/usr'
+ '--with-gtk=2.0'
+)
+
pkgver() {
cd "${srcdir}/${_upstream}"
git describe --long --tags|sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
@@ -35,7 +39,7 @@ build() {
cd "${srcdir}/${_upstream}"
NOCONFIGURE=1 ./autogen.sh
- LIBS+="-lm -ldl" ./configure --prefix=/usr --with-gtk=2.0
+ LIBS+="-lm -ldl" ./configure "${_configure_opts[@]}"
make
}