summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2017-04-04 12:07:06 -0700
committerShadowKyogre2017-04-04 12:07:06 -0700
commitc4faa9160f6dfc450775e2ccb976c8658d3bd178 (patch)
treed4da2b9611104d03501763989746bdbbdf469b58
downloadaur-c4faa9160f6dfc450775e2ccb976c8658d3bd178.tar.gz
Make emerald-gtk3-git
-rw-r--r--.SRCINFO32
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD50
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..babddb7de69c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+# Generated by mksrcinfo v8
+# Tue Apr 4 19:06:59 UTC 2017
+pkgbase = emerald-gtk3-git
+ pkgdesc = Emerald window decorator
+ pkgver = 0.8.12.4.r38.gd3eba71
+ pkgrel = 1
+ url = https://github.com/compiz-reloaded/emerald
+ arch = i686
+ arch = x86_64
+ groups = compiz-fusion
+ groups = compiz-fusion-kde
+ groups = compiz-fusion-gtk
+ license = GPL
+ makedepends = intltool
+ makedepends = pkg-config
+ makedepends = gettext
+ depends = compiz-core-git
+ depends = libxres
+ depends = shared-mime-info
+ depends = xdg-utils
+ depends = libwnck3
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ provides = emerald
+ conflicts = emerald0.9
+ conflicts = emerald
+ options = !libtool
+ source = git+https://github.com/compiz-reloaded/emerald.git
+ sha1sums = SKIP
+
+pkgname = emerald-gtk3-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a5401c5d685d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ad31e99e068
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# $Id$
+# Maintainer: martadinata666 <martadinata666@gmail.com>
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+# Contributor: JJDaNiMoTh <jjdanimoth@gmail.com>
+# Contributor: nesl247 <nesl247@gmail.com>
+
+_upstream="emerald"
+
+pkgname=emerald-gtk3-git
+pkgver=0.8.12.4.r38.gd3eba71
+pkgrel=1
+pkgdesc="Emerald window decorator"
+arch=('i686' 'x86_64')
+url="https://github.com/compiz-reloaded/${_upstream}"
+license=('GPL')
+depends=('compiz-core-git' 'libxres' 'shared-mime-info' 'xdg-utils' 'libwnck3'
+ 'desktop-file-utils' 'hicolor-icon-theme')
+makedepends=('intltool' 'pkg-config' 'gettext')
+groups=('compiz-fusion' 'compiz-fusion-kde' 'compiz-fusion-gtk')
+options=(!libtool)
+conflicts=('emerald0.9' 'emerald')
+provides=('emerald')
+source=(
+ "git+https://github.com/compiz-reloaded/${_upstream}.git"
+)
+sha1sums=('SKIP')
+
+_configure_opts=(
+ '--prefix=/usr'
+ '--with-gtk=3.0'
+)
+
+pkgver() {
+ cd "${srcdir}/${_upstream}"
+ git describe --long --tags|sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_upstream}"
+
+ NOCONFIGURE=1 ./autogen.sh
+ LIBS+="-lm -ldl" ./configure "${_configure_opts[@]}"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_upstream}"
+ make DESTDIR="${pkgdir}" install
+}