summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrimi2018-02-02 18:34:45 +0100
committergrimi2018-02-02 18:34:45 +0100
commit644a52cb155845e76d649865659a4e06cacae408 (patch)
tree4217cb94022c2ecbb088e593b783de5400920a35
parent700c6bb9f70903036fe6469a1311e2c54a4d287f (diff)
downloadaur-644a52cb155845e76d649865659a4e06cacae408.tar.gz
Upstream: 20180202
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 9 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 376a68d5ba1b..fd6c6f382a39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = emerald-icon-theme
pkgdesc = Fresh and simple personality icon theme
- pkgver = 2.7
+ pkgver = 20180202
pkgrel = 1
- epoch = 1
url = https://www.gnome-look.org/p/1012534
arch = any
license = GPL3
depends = hicolor-icon-theme
- source = https://dl.opendesktop.org/api/files/downloadfile/id/1515376357/s/eb09032c0d9d77d3f9bf5b60f2efa958/t/1515392250/emerald-icon-theme.tar.xz
- sha256sums = 5d7c5dfcf6ace0c859e7dbc2e11ca729eec3be9e5d267f2339cb185c0e7df2d8
+ source = emerald-icon-theme-2018.02.02.tar.gz::https://github.com/vinceliuice/emerald-icon-theme/archive/2018.02.02.tar.gz
+ sha256sums = c97571d8ceba34ba18940336a68ee85cacd8d2f48553570b3b8a29829f100555
pkgname = emerald-icon-theme
diff --git a/PKGBUILD b/PKGBUILD
index d177f46fcb90..527265135311 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,21 @@
# Maintainer: grimi <grimi at poczta dot fm>
+_pkgver=2018.02.02
pkgname=emerald-icon-theme
-pkgver=2.7
+pkgver=${_pkgver//\./}
pkgrel=1
-epoch=1
pkgdesc="Fresh and simple personality icon theme"
arch=('any')
url='https://www.gnome-look.org/p/1012534'
license=('GPL3')
depends=('hicolor-icon-theme')
-_hash_time=($(curl -s "$url"|grep -e "hash =" -e "timetamp ="|sed "s/.*= '\(.*\)';/\1/"))
-source=("https://dl.opendesktop.org/api/files/downloadfile/id/1515376357/s/${_hash_time[0]}/t/${_hash_time[1]}/${pkgname}.tar.xz")
-sha256sums=('5d7c5dfcf6ace0c859e7dbc2e11ca729eec3be9e5d267f2339cb185c0e7df2d8')
+source=("${pkgname}-${_pkgver}.tar.gz::https://github.com/vinceliuice/${pkgname}/archive/${_pkgver}.tar.gz")
+sha256sums=('c97571d8ceba34ba18940336a68ee85cacd8d2f48553570b3b8a29829f100555')
-prepare() {
- cd ${pkgname}
- sed -i 's/\(Inherits=\).*$/\1breeze,Arc,elementary,Adwaita,hicolor/' Emerald/index.theme
-}
-
package() {
- cd ${pkgname}
+ cd ${pkgname}-${_pkgver}
find Emerald{,-Dark,-Matcha}/ -type f -exec install -Dm644 "{}" "${pkgdir}/usr/share/icons/{}" \;
- find Emerald{,-Dark,-Matcha}/ -type l -exec cp -d "{}" "${pkgdir}/usr/share/icons/{}" \;
+ find Emerald{,-Dark,-Matcha}/ -type l -exec cp -d "{}" "${pkgdir}/usr/share/icons/{}" \;
}