summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2019-01-17 23:59:33 -0500
committerTony Lambiris2019-01-17 23:59:33 -0500
commit8d93263ac2a5a2ade67a10376c991b90c906615e (patch)
tree9f775ff0728d886ea60030c01030a2a46cc9fcac
downloadaur-8d93263ac2a5a2ade67a10376c991b90c906615e.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..34d1112e64e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = emerald-icon-theme-git
+ pkgdesc = Fresh and simple personality icon theme
+ pkgver = 2018.02.02.r16.ge8d0de4
+ pkgrel = 1
+ url = https://github.com/vinceliuice/emerald-icon-theme
+ arch = any
+ license = Custom
+ provides = emerald-icon-theme
+ conflicts = emerald-icon-theme
+ source = emerald-icon-theme-git::git+https://github.com/vinceliuice/emerald-icon-theme
+ sha256sums = SKIP
+
+pkgname = emerald-icon-theme-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..08194abeda4e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+emerald-icon-theme-git
+*pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14af051f3489
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Tony Lambiris <tony@criticalstack.com>
+
+pkgname=emerald-icon-theme-git
+pkgver=2018.02.02.r16.ge8d0de4
+pkgrel=1
+pkgdesc="Fresh and simple personality icon theme"
+arch=('any')
+url="https://github.com/vinceliuice/emerald-icon-theme"
+license=('Custom')
+conflicts=('emerald-icon-theme')
+provides=('emerald-icon-theme')
+source=("${pkgname}::git+https://github.com/vinceliuice/emerald-icon-theme")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ install -dm 755 "${pkgdir}/usr/share/icons"
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ cp -a "${srcdir}/${pkgname}/Emerald" "${pkgdir}/usr/share/icons/Emerald"
+}