summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVinícius dos Santos Oliveira2023-04-30 08:30:02 -0300
committerVinícius dos Santos Oliveira2023-04-30 08:30:02 -0300
commit915cfb37d78de50265d38cda66c1a4161be5c543 (patch)
tree9c655b1ed8aeecbdc5e66a1feac78cb863d4c832
downloadaur-915cfb37d78de50265d38cda66c1a4161be5c543.tar.gz
create package
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD21
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..53321090de5c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = emilua-qt5
+ pkgdesc = Qt5 bindings for Emilua
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://gitlab.com/emilua/qt5
+ arch = i686
+ arch = x86_64
+ license = boost
+ makedepends = git
+ makedepends = meson
+ makedepends = boost
+ makedepends = gawk
+ makedepends = gperf
+ makedepends = asciidoctor
+ depends = emilua
+ depends = qt5-declarative
+ source = emilua-qt5::git+https://gitlab.com/emilua/qt5.git#tag=v1.0.0
+ md5sums = SKIP
+
+pkgname = emilua-qt5
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ffb2ffa45e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Vinícius dos Santos Oliveira <vini.ipsmaker@gmail.com>
+pkgname=emilua-qt5
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Qt5 bindings for Emilua"
+arch=('i686' 'x86_64')
+url="https://gitlab.com/emilua/qt5"
+license=('boost')
+depends=('emilua' 'qt5-declarative')
+makedepends=('git' 'meson' 'boost' 'gawk' 'gperf' 'asciidoctor')
+source=("${pkgname}::git+https://gitlab.com/emilua/qt5.git#tag=v${pkgver}")
+md5sums=('SKIP')
+
+build() {
+ arch-meson "${pkgname}" build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="$pkgdir/" meson install -C build
+}