summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVinícius dos Santos Oliveira2023-04-30 08:31:19 -0300
committerVinícius dos Santos Oliveira2023-04-30 08:31:19 -0300
commit77c7f74225e860b24b8c53ea8be951066a86d8d5 (patch)
tree341d90b51d9909a7a67902df97261bf96bdd3812
downloadaur-77c7f74225e860b24b8c53ea8be951066a86d8d5.tar.gz
create package
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD21
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..080f6258f9df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = emilua-qt6
+ pkgdesc = Qt6 bindings for Emilua
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://gitlab.com/emilua/qt6
+ arch = i686
+ arch = x86_64
+ license = boost
+ makedepends = git
+ makedepends = meson
+ makedepends = boost
+ makedepends = gawk
+ makedepends = gperf
+ makedepends = asciidoctor
+ depends = emilua
+ depends = qt6-declarative
+ source = emilua-qt6::git+https://gitlab.com/emilua/qt6.git#tag=v1.0.0
+ md5sums = SKIP
+
+pkgname = emilua-qt6
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a467d2ecbb82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Vinícius dos Santos Oliveira <vini.ipsmaker@gmail.com>
+pkgname=emilua-qt6
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Qt6 bindings for Emilua"
+arch=('i686' 'x86_64')
+url="https://gitlab.com/emilua/qt6"
+license=('boost')
+depends=('emilua' 'qt6-declarative')
+makedepends=('git' 'meson' 'boost' 'gawk' 'gperf' 'asciidoctor')
+source=("${pkgname}::git+https://gitlab.com/emilua/qt6.git#tag=v${pkgver}")
+md5sums=('SKIP')
+
+build() {
+ arch-meson "${pkgname}" build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="$pkgdir/" meson install -C build
+}