summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnna Schumaker2023-05-16 11:12:08 -0400
committerAnna Schumaker2023-05-24 14:08:09 -0400
commitc1c0847718a15224a6100de220e4326ea3ec2f6c (patch)
treebd844938ddf963c4d55ee97ccc99f3f6099d9f1f
parent405e47e0215ddb9b02b0fdc2ac913583341ba2f4 (diff)
downloadaur-c1c0847718a15224a6100de220e4326ea3ec2f6c.tar.gz
Emmental 3.0
Signed-off-by: Anna Schumaker <Anna.Schumaker@Netapp.com>
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD32
2 files changed, 43 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08a879ec56ff..d7281f69f42d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,30 @@
pkgbase = emmental
pkgdesc = The cheesy music player
- pkgver = 2.10
+ pkgver = 3.0
pkgrel = 1
url = https://www.git.nowheycreamery.com/anna/emmental
arch = any
license = GPL3
- depends = python
+ checkdepends = flake8
+ checkdepends = python-pytest
+ checkdepends = python-pytest-timeout
+ checkdepends = python-pytest-subtests
+ makedepends = git
+ makedepends = desktop-file-utils
+ depends = gstreamer
+ depends = gst-plugins-base
+ depends = gtk4
+ depends = libadwaita
+ depends = python-dateutil
depends = python-gobject
+ depends = python-musicbrainzngs
depends = python-mutagen
depends = python-pyxdg
- depends = gtk4
- depends = gstreamer
- depends = gst-plugins-base
+ depends = xdg-user-dirs-gtk
optdepends = gst-plugins-good
optdepends = gst-plugins-bad
optdepends = gst-plugins-ugly
- source = https://git.nowheycreamery.com/anna/emmental/archive/emmental-2.10.tar.gz
- sha256sums = 110e5a4ee085987d7b7196505f382943b94b827332b67f8341d70dedcfbcd71f
+ source = https://git.nowheycreamery.com/anna/emmental/archive/emmental-3.0.tar.gz
+ sha256sums = f80a79f4a966a92496658aa683e5f40cd799839ff0af3e4dfba140276f6ebdfd
pkgname = emmental
diff --git a/PKGBUILD b/PKGBUILD
index a6acd786096c..ddaa5610632f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,41 @@
# Maintainer: Anna Schumaker <anna@nowheycreamery.com>
pkgname=emmental
-pkgver=2.10
+pkgver=3.0
pkgrel=1
pkgdesc='The cheesy music player'
url='https://www.git.nowheycreamery.com/anna/emmental'
arch=('any')
license=('GPL3')
-depends=('python' 'python-gobject' 'python-mutagen' 'python-pyxdg' 'gtk4' 'gstreamer' 'gst-plugins-base')
-optdepends=('gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly')
+depends=(gstreamer gst-plugins-base gtk4 libadwaita python-dateutil python-gobject python-musicbrainzngs python-mutagen python-pyxdg xdg-user-dirs-gtk)
+makedepends=(git desktop-file-utils)
+optdepends=(gst-plugins-good gst-plugins-bad gst-plugins-ugly)
+checkdepends=(flake8 python-pytest python-pytest-timeout python-pytest-subtests)
source=("https://git.nowheycreamery.com/anna/emmental/archive/emmental-$pkgver.tar.gz")
-sha256sums=(110e5a4ee085987d7b7196505f382943b94b827332b67f8341d70dedcfbcd71f)
+sha256sums=(f80a79f4a966a92496658aa683e5f40cd799839ff0af3e4dfba140276f6ebdfd)
+
+prepare() {
+ cd $pkgname
+ if [ ! -f "mpris-spec/Makefile" ]; then
+ git clone https://gitlab.freedesktop.org/mpris/mpris-spec.git
+ fi
+}
+
+build() {
+ cd $pkgname
+ make mpris2
+ make emmental.gresource
+}
package() {
- cd "$pkgname"
+ cd $pkgname
make PREFIX="$pkgdir/usr" install
sed -i "s|$pkgdir||" $pkgdir/usr/bin/emmental
sed -i "s|$pkgdir||" $pkgdir/usr/share/applications/emmental.desktop
+ desktop-file-edit --set-key=StartupWMClass --set-value=emmental.py $pkgdir/usr/share/applications/emmental.desktop
+ rm -f "$pkgdir/usr/share/applications/mimeinfo.cache"
+}
+
+check() {
+ cd $pkgname
+ make tests
}