summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorr3b311i0n2018-01-14 17:46:37 +0530
committerr3b311i0n2018-01-14 17:46:37 +0530
commit6666a4c19f589af1d529e0c19bc544853925fdb8 (patch)
treea31583364b36dee52667ba3ecd31bb15582eda64
downloadaur-6666a4c19f589af1d529e0c19bc544853925fdb8.tar.gz
Init :scream:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
-rw-r--r--emoji-cli-git.install6
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..517d931648d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = emoji-cli-git
+ pkgdesc = Emoji completion on the command line for ZSH.
+ pkgver = r34.5179c1e
+ pkgrel = 1
+ url = https://github.com/b4b4r07/emoji-cli
+ install = emoji-cli-git.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = zsh
+ depends = jq
+ depends = fzf
+ depends = peco
+ conflicts = emoji-cli
+ options = !strip
+ source = git+https://github.com/b4b4r07/emoji-cli.git
+ source = LICENSE::http://b4b4r07.mit-license.org
+ sha256sums = SKIP
+ sha256sums = cbd6dff5609dd1b5523a882b118bd1f966288eb103105792016e8302f5d115e8
+
+pkgname = emoji-cli-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2eef4c0f4a8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Amal Karunarathna <nasashinega@gmail.com>
+
+_gitname=emoji-cli
+pkgname=emoji-cli-git
+pkgver=r34.5179c1e
+pkgrel=1
+pkgdesc="Emoji completion on the command line for ZSH."
+arch=('any')
+url="https://github.com/b4b4r07/${_gitname}"
+license=('MIT')
+depends=('zsh'
+ 'jq'
+ 'fzf'
+ 'peco')
+makedepends=('git')
+conflicts=('emoji-cli')
+options=('!strip')
+install="${pkgname}.install"
+source=("git+${url}.git"
+ 'LICENSE::http://b4b4r07.mit-license.org')
+sha256sums=('SKIP'
+ 'cbd6dff5609dd1b5523a882b118bd1f966288eb103105792016e8302f5d115e8')
+
+pkgver(){
+ cd ${_gitname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${srcdir}/${_gitname}/dict/emoji.json" "${pkgdir}/usr/share/zsh/plugins/${_gitname}/dict/emoji.json"
+ install -Dm644 "${srcdir}/${_gitname}/emoji-cli"{.plugin,}".zsh" "${pkgdir}/usr/share/zsh/plugins/${_gitname}"
+}
diff --git a/emoji-cli-git.install b/emoji-cli-git.install
new file mode 100644
index 000000000000..33cb04af1b82
--- /dev/null
+++ b/emoji-cli-git.install
@@ -0,0 +1,6 @@
+post_install() {
+ cat << EOF
+To activate emoji-cli add the following line at the end of ~/.zshrc:
+ source /usr/share/zsh/plugins/emoji-cli/emoji-cli.zsh
+EOF
+} \ No newline at end of file