summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFredrik Strandin2017-10-22 11:27:03 +0200
committerFredrik Strandin2017-10-22 11:27:03 +0200
commit1759a4d6cfe95d74dc81131125363d4e36c691a5 (patch)
treefbd5d63fe7ca3bbc5a366142d6366427a82c55f5
parent761c8ed0a1a897bdd9b5422885c182c3ac3414a8 (diff)
downloadaur-1759a4d6cfe95d74dc81131125363d4e36c691a5.tar.gz
Fix new svg-path and dependency
* 2.2.0 started using evdev in favor of xlib * Also added explicit dependency on python-gobject since it was missing * Added a patch for setup.py fixing the path for the svg files to be included
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
-rw-r--r--fix_svg_path.patch13
3 files changed, 30 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64d7a5e6888d..139b9771b085 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = emoji-keyboard
pkgdesc = Virtual keyboard-like emoji picker for linux
pkgver = 2.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/OzymandiasTheGreat/emoji-keyboard
arch = i686
arch = x86_64
license = GPL3
depends = python
- depends = python-xlib
+ depends = python-gobject
depends = libappindicator-gtk3
+ depends = python-evdev
source = https://github.com/OzymandiasTheGreat/emoji-keyboard/archive/2.2.0.tar.gz
+ source = fix_svg_path.patch
sha256sums = 39e4e9edb1d3f75a73f4161289a4586d77a8b4c0c9743437e7239e5976ea157c
+ sha256sums = 2bb58538962ff65fa60152e45891faf5b7ccb531e87b05753162f365483b68a3
pkgname = emoji-keyboard
diff --git a/PKGBUILD b/PKGBUILD
index 73779f35fa00..1fd587729bff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,22 @@
# Maintainer: Fredrik Strandin <fredrik at strandin dot name>
pkgname=emoji-keyboard
pkgver=2.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Virtual keyboard-like emoji picker for linux"
arch=('i686' 'x86_64')
url="https://github.com/OzymandiasTheGreat/emoji-keyboard"
license=('GPL3')
-depends=('python' 'python-xlib' 'libappindicator-gtk3')
-source=("https://github.com/OzymandiasTheGreat/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('39e4e9edb1d3f75a73f4161289a4586d77a8b4c0c9743437e7239e5976ea157c')
+depends=('python' 'python-gobject' 'libappindicator-gtk3' 'python-evdev')
+source=("https://github.com/OzymandiasTheGreat/${pkgname}/archive/${pkgver}.tar.gz"
+ "fix_svg_path.patch")
+sha256sums=('39e4e9edb1d3f75a73f4161289a4586d77a8b4c0c9743437e7239e5976ea157c'
+ '2bb58538962ff65fa60152e45891faf5b7ccb531e87b05753162f365483b68a3')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+
+ patch -Np1 -i "${srcdir}/fix_svg_path.patch"
+}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/fix_svg_path.patch b/fix_svg_path.patch
new file mode 100644
index 000000000000..f581e3163f56
--- /dev/null
+++ b/fix_svg_path.patch
@@ -0,0 +1,13 @@
+diff -ura emoji-keyboard-2.2.0/setup.py emoji-keyboard-2.2.0+patched/setup.py
+--- emoji-keyboard-2.2.0/setup.py 2017-10-17 23:30:03.000000000 +0200
++++ emoji-keyboard-2.2.0+patched/setup.py 2017-10-22 11:18:01.805710441 +0200
+@@ -38,8 +38,7 @@
+ packages=['emoji_keyboard'],
+ package_data={'emoji_keyboard': [
+ 'data/*.json',
+- 'data/svg/*.svg',
+- 'data/category_icons/*.svg',
++ 'data/*/*.svg',
+ 'data/emoji-keyboard.desktop']},
+ data_files=data_files,
+ scripts=['emoji-keyboard'],