summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2023-10-11 02:53:30 +0200
committerbegin-theadventure2023-10-11 02:53:30 +0200
commitbd9ce7174087813af32ab301e52f87df9d44643b (patch)
tree87d4af8caa2604eee6e3a28688df6db06bafa501
downloadaur-bd9ce7174087813af32ab301e52f87df9d44643b.tar.gz
4.0.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f24cb7e524e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = emoji-keyboard-bin
+ pkgdesc = Type emoji easily! Virtual keyboard-like emoji palette for Linux with [fewer] of features (binary release)
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = https://github.com/OzymandiasTheGreat/emoji-keyboard
+ arch = x86_64
+ license = MIT
+ source = https://github.com/OzymandiasTheGreat/emoji-keyboard/releases/download/v4.0.0/emoji-keyboard_4.0.0_amd64.deb
+ source = https://github.com/OzymandiasTheGreat/emoji-keyboard/raw/v4.0.0/LICENSE
+ sha256sums = bfc9c56bc3355dd5d2b5f44451eea8ec6b41f7c8afbe6370b38f18a80b083873
+ sha256sums = SKIP
+
+pkgname = emoji-keyboard-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28663c36ff11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+
+_pkgname=emoji-keyboard
+pkgname=$_pkgname-bin
+pkgver=4.0.0
+pkgrel=1
+pkgdesc='Type emoji easily! Virtual keyboard-like emoji palette for Linux with [fewer] of features (binary release)'
+url="https://github.com/OzymandiasTheGreat/emoji-keyboard"
+arch=('x86_64')
+license=('MIT')
+source=("$url/releases/download/v$pkgver/${_pkgname}_${pkgver}_amd64.deb"
+ "$url/raw/v$pkgver/LICENSE")
+sha256sums=('bfc9c56bc3355dd5d2b5f44451eea8ec6b41f7c8afbe6370b38f18a80b083873'
+ 'SKIP')
+
+prepare() {
+ tar -xf data.tar.gz
+}
+
+package() {
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$_pkgname"
+ cd usr
+ install -Dm644 share/applications/$_pkgname.desktop -t "$pkgdir/usr/share/applications"
+ for i in 32x32 128x128 256x256@2; do
+ install -Dm644 share/icons/hicolor/$i/apps/$_pkgname.png -t "$pkgdir/usr/share/icons/hicolor/$i/apps"
+ done
+ install -Dm755 bin/$_pkgname -t "$pkgdir/usr/bin"
+}