summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordtluna2019-03-30 15:24:12 +0300
committerdtluna2019-03-30 15:24:12 +0300
commit9c5a3852d0d481d77473df3ab0a230319f35dddb (patch)
tree65c3e36b6abb0c765d7847220baa37eb3986ef8d
downloadaur-9c5a3852d0d481d77473df3ab0a230319f35dddb.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c50015c3772e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emoji-stealer-bin
+ pkgdesc = Emoji stealer for Mastodon and Pleroma
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://git.dtluna.net/dtluna/emoji_stealer
+ arch = x86_64
+ arch = i686
+ license = custom:WTFPL
+ conflicts = emoji-stealer
+ source_x86_64 = emoji-stealer-bin_1.1.0_linux_x86_64.zip::https://git.dtluna.net/attachments/5874b866-e7f7-43f3-8c14-43b57f2cf746
+ sha256sums_x86_64 = 1753350f37764e7936a00b1b967a2fb46c44cf5d0dac3a86538609a96c92ede4
+ source_i686 = emoji-stealer-bin_1.1.0_linux_i686.zip::https://git.dtluna.net/attachments/b2dae06e-21f5-4eba-b3fc-fb393167a399
+ sha256sums_i686 = 5464a7804f4a06b7238737a28c5f5e13315c936e2ec0fe4a761a85f660987318
+
+pkgname = emoji-stealer-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..31d27563afeb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..541d573ea7cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: dtluna <dtluna at waifu dot club>
+
+_pkgname_base='emoji-stealer'
+pkgname="${_pkgname_base}-bin"
+_pkgname='emoji_stealer'
+pkgver='1.1.0'
+pkgrel=1
+pkgdesc='Emoji stealer for Mastodon and Pleroma'
+url='https://git.dtluna.net/dtluna/emoji_stealer'
+arch=('x86_64' 'i686')
+license=('custom:WTFPL')
+
+depends=()
+makedepends=()
+optdepends=()
+
+conflicts=("${_pkgname_base}")
+
+source_x86_64=("${pkgname}_${pkgver}_linux_x86_64.zip::https://git.dtluna.net/attachments/5874b866-e7f7-43f3-8c14-43b57f2cf746")
+source_i686=("${pkgname}_${pkgver}_linux_i686.zip::https://git.dtluna.net/attachments/b2dae06e-21f5-4eba-b3fc-fb393167a399")
+
+sha256sums_x86_64=('1753350f37764e7936a00b1b967a2fb46c44cf5d0dac3a86538609a96c92ede4')
+sha256sums_i686=('5464a7804f4a06b7238737a28c5f5e13315c936e2ec0fe4a761a85f660987318')
+
+
+package() {
+ # Bin
+ rm -f "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm755 "${srcdir}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname_base}"
+
+ # License
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname_base}/LICENSE"
+}
+