summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2016-11-29 11:46:23 +1100
committerRhinoceros2016-11-29 11:46:23 +1100
commit261235536bb97ead32a5798281bd4fdebe3ea300 (patch)
tree6232b2178208099fa7b40d00fd1fd64dcc0cc92a
downloadaur-261235536bb97ead32a5798281bd4fdebe3ea300.tar.gz
Initial commit of 0.1.r37.gcb5f504-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f24308b21535
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Tue Nov 29 00:46:15 UTC 2016
+pkgbase = emojione-picker-git
+ pkgdesc = Emoji picker based on icons by Emojione
+ pkgver = 0.1.r37.gcb5f504
+ pkgrel = 1
+ url = https://github.com/gentakojima/emojione-picker-ubuntu
+ arch = any
+ license = GPL3;cc-by-4.0
+ makedepends = git
+ depends = python2
+ source = git+https://github.com/gentakojima/emojione-picker-ubuntu.git
+ sha256sums = SKIP
+
+pkgname = emojione-picker-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8fa80199cb42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+
+pkgname=emojione-picker-git
+pkgver=0.1.r37.gcb5f504
+pkgrel=1
+pkgdesc='Emoji picker based on icons by Emojione '
+arch=('any')
+url='https://github.com/gentakojima/emojione-picker-ubuntu'
+license=('GPL3;cc-by-4.0')
+depends=('python2')
+makedepends=('git')
+source=('git+https://github.com/gentakojima/emojione-picker-ubuntu.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd 'emojione-picker-ubuntu'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd 'emojione-picker-ubuntu'
+ # remove hard-coded install paths, warnings and confirmations
+ <install.sh sed 's/^\W*_INSTALL_PREFIX=.*/true/' | grep '^\W*_AUTOSTART_DIR=' -v | grep '^\W*_APP_DIR=' -v | grep 'the program will be installed just for the current user.' -v | grep 'Press enter to install' -v | grep echo -v > install_for_pkgbuild.sh
+ chmod +x install_for_pkgbuild.sh
+}
+
+package() {
+ cd 'emojione-picker-ubuntu'
+ export _INSTALL_PREFIX="${pkgdir}/usr/local/"
+ export _AUTOSTART_DIR="${pkgdir}/etc/xdg/autostart"
+ export _APP_DIR="${pkgdir}/usr/local/share/applications"
+ ./install_for_pkgbuild.sh
+}