summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraziano.giuliani2015-07-04 16:41:04 +0200
committergraziano.giuliani2015-07-04 16:41:04 +0200
commite93bb586fb68ef517822dfd2cc6053a831f85bb3 (patch)
tree366a6a39b2e2832ee648e37041a5261b02d73dd1
downloadaur-e93bb586fb68ef517822dfd2cc6053a831f85bb3.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3627e4c3a2a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = emos
+ pkgdesc = ECMWF Interpolation Library
+ pkgver = 4.0.3
+ pkgrel = 2
+ url = https://software.ecmwf.int/wiki/display/EMOS/Emoslib
+ arch = i686
+ arch = x86_64
+ groups = science
+ license = Apache
+ makedepends = grib_api
+ makedepends = boost
+ makedepends = git
+ makedepends = cmake
+ options = staticlibs
+ source = https://software.ecmwf.int/wiki/download/attachments/3473472/libemos-4.0.3-Source.tar.gz
+ md5sums = b77391eb6ea904903e86013056602ec7
+
+pkgname = emos
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d99f7aea49e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Graziano Giuliani <graziano.giuliani@gmail.com>
+pkgname=emos
+pkgver=4.0.3
+pkgrel=2
+pkgdesc="ECMWF Interpolation Library"
+arch=(i686 x86_64)
+url="https://software.ecmwf.int/wiki/display/EMOS/Emoslib"
+license=('Apache')
+groups=(science)
+depends=()
+makedepends=(grib_api boost git cmake)
+options=('staticlibs')
+source=(https://software.ecmwf.int/wiki/download/attachments/3473472/libemos-4.0.3-Source.tar.gz)
+md5sums=('b77391eb6ea904903e86013056602ec7')
+
+build() {
+ cd ${srcdir}/lib${pkgname}-${pkgver}-Source
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=production ..
+ make
+}
+
+package() {
+ cd ${srcdir}/lib${pkgname}-${pkgver}-Source/build
+ make DESTDIR=${pkgdir} install
+}
+
+# vim:set ts=2 sw=2 et: